I have a late 2012 Mac mini, 2.5 GHz Intel Core i5, running OS X Yosemite version 10.10.5 (14F27). Recently, just after the delta update to 10.10.5, two of my apps, uTorrent and All2MP3 have started crashing with the following error:

objc[5240]: Class  is implemented in both /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit and /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit. One of the two will be used. Which one is undefined.

How can I fix this?

  • Could you upload the actual crash log to the post or to a git hub gist? that error message is not fatal - I have thousands of instances where it's logged and no crashes result. Something else is likely causing the crash - even if this is highly correlated to the issue. Also, what build version is your OS X and what versions of the apps? – bmike Aug 25 '15 at 20:11
  • Did you reinstall the latest 10.10 compatible versions of these apps? – MicroMachine Sep 11 '15 at 22:32

Just guessing:

My standard install of OS X Yosemite 10.10.5 doesn't contain the file /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit..

Please check the following:

  1. the currentness of your backup
  2. The proper destination of the soft link "Current" in the folder /System/Library/Frameworks/AppKit.framework/Versions/. It should be /System/Library/Frameworks/AppKit.framework/Versions/C/.
  3. Does the folder /System/Library/Frameworks/AppKit.framework/Versions/C/ contain a second file named Appkit.?
  4. If the folder /System/Library/Frameworks/AppKit.framework/Versions/C/ contains a second file named Appkit., check the md5s (md5 /path/to/file) of the files Appkit and Appkit.. The md5 of the file Appkit in my system is 5404e155c41dedd1bea5e29bf02182d8 (size=39.450.864 bytes, mod date 2nd of June 2015). If you have 2 files Appkit and Appkit. with identical and correct md5s move Appkit. to a save place with:

    sudo mv "/System/Library/Frameworks/AppKit.framework/Versions/C/Appkit." "/System/Library/Frameworks/Appkit."

    If one has the correct md5 and the other a wrong md5, remove the file with wrong md5 and if necessary rename the correct one to "Appkit". If both md5s are wrong reinstall 10.10.5 with the 10.10.5 Combo Updater. Reboot your Mac and test the behavior of µTorrent. If the testing with µTorrent gave a positive result remove the file /System/Library/Frameworks/Appkit.

  5. If the folder doesn't contain a file named "Appkit." at all boot to your Recovery HD and try repair your main volume.

  • I only have one AppKit executable. I tried repairing the disk, but Disk Utility insists that it is fine. – Vatsal Manot Aug 26 '15 at 11:35
  • @VatsalManot And AppKit has a proper md5? – klanomath Aug 26 '15 at 11:37
  • AppKit has an MD5 of ad2601d3e17bc140936b4861bf34dcc0 – Vatsal Manot Aug 26 '15 at 11:39
  • @VatsalManot That's different to the md5 I've found in my OS X install. Simply download the 10.10.5 Combo Installer and run it. – klanomath Aug 26 '15 at 11:43

Try repairing disk permissions and if that doesn't solve the issue then simply reinstall them. Reinstalling the app may fix the problem.


I had the same problem several programs would not launch. I ended up reinstalling yosemite (with out deleting my data) that fixed it. Before that I had tried repairing disk permissions with out any success.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .