4

I have installed the latest beta of OS X, El Capitan 10.11. The mail app said it needed to index mail. when it finished that process the mail app crashed. Now it refuses to open. Mail has been rendered unusable with this upgrade, for me.

Anyone have any ideas of things I could try to fix this? Thanks.

  • I can share the error report, if needed. – Sizzle Aug 20 '15 at 15:12
  • 10.11 Beta (15A262e) Thanks for the response. I have rebooted twice. – Sizzle Aug 20 '15 at 15:22
  • the error report has too many characters to post – Sizzle Aug 20 '15 at 15:27
  • reset the RAM as well. Still nada. – Sizzle Aug 20 '15 at 16:05
  • Good info. Please add these to your question using the edit link. – bjbk Aug 20 '15 at 16:13

10 Answers 10

11

I have to remove a PGP plug-in from /Library/Mail/Bundles to get the Mail App running again.

Just open Mail and immediately open Accounts, disable the accounts one by one to find out which one is causing the crash. Then delete this account completely and restart Mail. Then add the account all over again. It worked on my gmail account.

1

I have had the same issue - in my case it was caused by an account with incorrect settings. Yosemite tolerated this while El Capital crashes. I followed the suggestion and disabled wi-fi. Mail loaded. When I enabled wi-fi, it crashed immediately. I disabled the account and now it seems to work. El Capitan seems overly finicky on this.

0

It happened to me as well in El Capitan Beta 4. A simple reboot solved the problem. Since you also tried that, i'd suggest

  • empty caches (using cleanmymac or similars)
  • reset PRAM at startup
  • i will give those a shot. – Sizzle Aug 20 '15 at 18:00
  • 1
    too bad you can't Repair Permissions anymore, that would have been another great suggestion (what a stupid update in El Capitan) – AlessioX Aug 20 '15 at 18:03
  • @GothicAsFuck Doesn't El Cap add some new process that automatically manages permissions such that a repair is never needed? – user24601 Aug 20 '15 at 21:40
  • @user24601 True indeed, but if I remember correctly those processes are actually engaged only when you install new updates or new software. – AlessioX Aug 21 '15 at 6:52
  • thanks for the answers. the emails are on icloud as well. i ended up clearing caches, resetting PRAM....and then just doing a complete Time Machine back-up of my system from two days ago. I have not updated to the latest beta. – Sizzle Aug 21 '15 at 16:14
0

I had this problem and needed to clean out anything that had index in the name from this path: ~/Library/Mail/V2/MailData/

Now it seems to be coming back to life again.

0

Mail seems to stumble over incompatible bundles, at least on my system. I had to manually move Mail plugins installed in /Library/Mail/Bundles and ~/Library/Mail/Bundles out of the way to get Mail back up and running.

0

Mail would crash immediately upon attempting to open. My issue was resolved when I turned off wifi, which kept the mail accounts offline. I could open mail with wifi off but when I turned it back on, it would crash. I then could see mail, which allowed me to disable accounts. With wifi off, I deleted some of the accounts until I found which was the problem, which seemed to be the ones that I didn't use anyhow. I turned wifi back on and it seems to do fine now. It took a few times of turning it off and back on to isolate the issue.

  • Anything special these accounts have in common? – nohillside Sep 11 '15 at 9:08
0

I quit mail, removed everything in ~/Library/Mail/V2/MailData/ and relaunch mail.. then it started to import mail again and created V3 folder

0

If you have a symbolic link to move the mail to another drive, remove the link. That worked for me. Maybe there is new type of links in el capitan. will try it again when it fills

0

This was a quick fix I found:

Settings > Internet accounts > uncheck mail for each account > open mail > preferences > re-enable each account

0

Combining suggestions from Tim Lynch & Bella worked for me. Now Mail half way through downloading 20,000 emails ! 😁

By the way, under Yosemite, Mail had been crawling; so far so great with El Capitan; perhaps things will change when all 20K messages are downloaded!]

[iMac 27-inch late 2009; 12 GB]

  • 1
    This answer doesn't seem to answer the question. This looks more like a comment. Please move this to the comments section of the question. – chrisjr Oct 1 '15 at 16:14

You must log in to answer this question.

protected by Community Oct 2 '15 at 7:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .