18

It often takes me a while to find the mouse crosshair when working with Terminal.app. Is there a way to make it more visible?

6
  • 1
    Do you want to customize the mouse cursor (while you're moving it around), or the text cursor (that shows you where you are in some text)? Commented Aug 4, 2011 at 20:09
  • The mouse pointer that appears when I am over the Terminal.app window. I would like it to be something more visible than a crosshair.
    – nachocab
    Commented Aug 4, 2011 at 20:53
  • To be more clear, this is largely a problem if you have the terminal background set to black, or otherwise a very dark color. Unlike the arrow pointer, the text select hairpin doesn't have a border color of white to make it visible against any background.
    – Jherico
    Commented May 10, 2012 at 21:06
  • Did you find a solution yourself? :) It's very irritating especially with an external main monitor, the pointer gets lost on the side monitor
    – Kaan
    Commented Nov 11, 2014 at 8:36
  • @KaanSoral, nah, I just switched to a light background in iTerm to make it more visible
    – nachocab
    Commented Nov 11, 2014 at 23:08

4 Answers 4

4

There's an app available to download called Mouse Locator which will put green markers around your cursor if you press a hotkey. That might help you but I don't know if it's still a working program under current OS X releases.

1
  • Appears to be broken in Catalina.
    – TextGeek
    Commented May 3, 2020 at 20:00
1

I've started having this problem also, not sure if it started happening after i got a retina screen or upgraded to mavericks, or im just getting old. My suggestion is to try iTerm2 which have a bit more visible "hairpin".

1
  • I'm having this issue after upgrading to Yosimite from Mountain Lion. It is definitely dimmer. :/ Commented May 13, 2015 at 17:54
1

I had this problem in iTerm2, especially on a blurred tab with a darker background color. The mouse cursor became all but invisible.

Wiggling the mouse causes the mouse to get super-sized for a moment. (On macOS, unless you have "Shake the mouse to locate" disabled.) This is super-handy, especially if you have multiple large monitors. I'd been doing this for ages before deciding that was annoying, particularly with the iTerm2 scenario, which I hit dozens of times per day.

I tried a few different things, short of adding third-party software.

  • You can bump up the mouse pointer size (Display Settings > Pointer Size). It works fantastic but it looks a bit Mickey Mouse-ish and I couldn't stand it.
  • You can change the outline color. (Display Settings > Pointer Outline Color) A black outline solves the problem and only looks a little clunky. A colored outline (fuschia if that doesn't bother you) gives it even more pop. That's what worked best for me.
0

If you mean the blinking cursor, then you need to go into the terminal preferences. Here's a picture to help you better understand

Terminal Prefences

1
  • 3
    Thanks, Slick. But I meant the OSX pointer, it switches to a hairpin when you move it through the Terminal.app window, then it goes back to being an arrow.
    – nachocab
    Commented Aug 4, 2011 at 20:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .