1

The

open -a <AppName.app>

is not working on one of my Yosemite based macbooks. The other one - also with Yosemite - works fine.

open -a TextEdit.app ~/out

(just hangs )

I have also tried other apps - to make sure the problem were not specifically with TextEdit. Nothing works. Also I am able to use Finder to open apps with TextEdit.

AFA the app's attempted: let us look at a simple built-in one:

 $open -a TextEdit.app ~/out

Note that "open" has not been disturbed in any way: it is the one shipped with the MacBook

12:23:07/Applications $which open
/usr/bin/open

ls -lrta $(which open)
-rwxr-xr-x  1 root  wheel  92912 Sep 12  2014 /usr/bin/open
  • On the system having a problem, from Terminal, execute the following command, as is, and reports if TextEdit opens normally to a blank document or still hangs. open -a TextEdit – user3439894 Aug 19 '15 at 19:42
  • yes that hangs on iTerm2. I had realize a few minutes earlier that the issue appears to be with iTerm2 (vs Terminal). – javadba Aug 19 '15 at 19:43
1

It appears the issue were rather with iTerm2. I tried the same commands on Terminal and it worked fine. I do need some of the features of iTerm and am investigating which version(s) actually work. The one I am using (and does not work) is the one on the Download link. So far I am having better luck with their iTerm 3.0 Alpha version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .