Ever since i upgraded to lion, finder has been having problems for me. At first I thought my Quicksilver was broken when I tried to summon my downloads folder and it didnt appear.

I then went to desktop and clicked on a random folder and it also didn't appear. I then proceeded trying to open any folder with quicksilver and spotlight to no avail. I tried About Finder and still didnt see anything.

Fearing the worst, I restarted and tried to open up a folder again. Still nothing. What I did then was to hope and pray then force quit finder(force relaunch) and all the finder windows i tried to open now suddenly appeared.

This happens intermittently but usually after I shut down and open my mac again. Does this happen to any of you and do any of you know of the fix for this problem?

While writing this question, I had a slight hunch that it MIGHT be worth mentioning that my Finder is tied to Desktop 3 in spaces before(it doesn't have any problems with that though)

  • Well, dod you try to untie Finder from Desktop 3 to see if it changed something? Aug 4 '11 at 19:01
  • I have the EXACT same problem but I do not use Desktop 3 or Quicksilver, so you can rule those out.
    – user10509
    Aug 30 '11 at 14:36
  • hmm so how did you fix yours? it happens intermittently on mine so im figuring finder was crashing(i just force finder relaunch)
    – corroded
    Aug 31 '11 at 4:36
  • Same issue here. Finder is not assigned to any desktop. I'm forcing finder relaunch multiple times per day now. Did a full format/reinstall from the rescue partition - still no luck.
    – venables
    Dec 20 '11 at 17:12
  • any of you, by any chance are using antivirus, or folder synchronization tools like dropbox? any of you using disk encryption (specially the traditional, migrated from Leopard?)
    – Ali
    Dec 20 '11 at 20:53

Maybe your issues are tied to Quicksilver instead of Lion? It does not appear that Quicksilver officially supports Lion yet (http://qsapp.com/download.php) you might try the following things to ensure that Quicksilver has the greatest opportunity for success:

  1. Make sure you are running the latest version of Quicksilver (at time of writing that's ß60 for Snow Leopard).
  2. Quit Quicksilver, Remove ~/Library/Caches/Quicksilver/, Restart Quicksilver
  3. Check the FAQ for information on crashes: http://qsapp.com/wiki/FAQ#Quicksilver_crashes

If none of those work you could try uninstalling it and see if that fixes your issues. If it turns out that Quicksilver is the issue you might checkout http://alfredapp.com/ — I have no relation to the company but I have replaced Quicksilver on my machine with Alfred and would never go back.

  • actually i am also running alfred app. i use quicksilver to launch my apps and main folders, alfred to go into the sub folders and spotlight to search for specific files. it feels more 'natural' for me since none of the 3 could actually "read" my mind when im typing somethign to search
    – corroded
    Aug 5 '11 at 3:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .