2

I'm trying to connect my iPhone 3G(iOS 4.0.2) to an ad hoc wifi network that I've created on my netbook(running Fedora 13). When I attempt to connect, everything seems to go fine on both ends, however after the connection is established the 3G icon is never replaced by the wifi icon, even though there is a check next to the connection in the wifi selection screen.

wifi selection screen

I have also attempted to create an ad hoc wifi network on my PowerBook, and have exactly the same issues. I have also tried putting the phone in Airplane mode, and then connecting to the network but the wifi bars never appear. I've tested this with a friends iPhone 4 and the same thing happens.

I'm not attempting to share an internet connection over the ad hoc wifi network, my goal is to be able to control my netbook from my iPhone when I'm on the go and away from other wireless networks.

2

My guess is that the iPhone doesn't consider the connection valid because there's no DHCP service assigning it an IP or perhaps gateway allowing it access to the internet.

Try running a DHCP server on your laptop or enabling network sharing even if the laptop isn't on the net.

1

I had setup this kind of network and it works properly. However, i did on Windows 7 and iPhone 4. Not sure 100% that it works on your case but giving it a try. Pls follow:

  1. Your PowerBook connects to internet via LAN? Your LAN should use DHCP
  2. Setup adhoc network with WEP type then share internet.
  3. Click on wifi on the far right of status bar, choose your adhoc network and click connect.
  4. On your Iphone, click on the adhoc network and forget it
  5. Turn off/on wifi then reconnect to adhoc network
  6. Open safari and check internet connection

Hope it can help.

  • It still says Mobile Data is Turned Off.. it doesn't see it as a real wifi network? comes under a list of "devices" ? – hamish Nov 12 '16 at 1:56
  • ok now it works. I just clicked cancel on the "mobile data is turned off" and it then showed as a wifi connection.. I shouldn't have to do that. – hamish Nov 12 '16 at 1:57
  • Working great with OPEN networking. it didn't work with WPA2 – hamish Nov 12 '16 at 2:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .