1

I have a dual monitor setup on the Mac. I want to work on a tool, in full screen, on display 1 and simultaneously check few things, on Final Cut Pro, on display 2.

When I maximize the tool in display 1, I can't see the FCP in display 2.

Is there any third party tool to solve this, or is it an OS X limitation.

1

UPDATE 2

These are the support instructions for using multiple monitors with Mac OS X 10.8 (Mountain Lion) and earlier. You will likely want to use the Extended Desktop Settings. If you still doesn't let you see the other app, then check to see if FCP has an Always On Top setting which may be turned off, and don't have the apps set to full-screen mode.

UPDATE

This solution will only work if you are running Mac OS X 10.9 (Mavericks) or later. (Apologies as I missed in your question that 10.8 was Mountain Lion and not Mavericks).

enter image description here

If you do find it, then set that. Then go to one Desktop and Ctrl + Click on the FCP icon in the Dock and under Options, select This Desktop.

Then go to another desktop, Ctrl + Click on the other apps icon and under options select This Desktop.

Then you should be able to go to one monitor and select the FCP Desktop, move to the second monitor and select the other Apps Desktop and that should display both apps on the respective monitors.

This is Apple's support page for Multiple Displays.

| improve this answer | |
  • No, i don't have the 'Display have separate spaces' option on the mission control like you do (screenshot). Is there a way i can enable it or make it show up on the pane. – Mrityunjoy Aug 18 '15 at 21:34
  • Are you the admin on your Mac? Because otherwise I have no idea why that wouldn't be there unless something in your display settings is affecting the Mission Control Settings. Usually then it would only be grayed out... Try disconnecting one of the monitors and restarting and see if it is still missing. – AMR Aug 18 '15 at 21:38
  • I'm the admin . Disconnected the monitor. Restarted. But same thing :( – Mrityunjoy Aug 18 '15 at 21:53
  • That sounds like an ask Apple question... I guess if you have a good, recent back, you can go ahead and try and doing a reinstall of the OS... That seems extreme.... – AMR Aug 18 '15 at 21:56
  • 1
    Yes! looks like it is an OS limitation. Worked fine on 10.10, will upgrade. Thanks – Mrityunjoy Aug 19 '15 at 0:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .