4

I updated my iTunes on my computer, and one of the things I noticed was that the "iCloud Download" column had now appeared on top of my music library. Now, I don't use iCloud for my music, so I right-clicked the bar and turned it off.

A few minutes later, the iCloud Download tab was back again. I could've sworn I'd turned it off, but just to be sure I right-clicked and turned it off again.

A few more minutes pass, and the iCloud Download tab is right there back again. Every time I turn it off, it just keeps reappearing sooner or later. I have Automatic Downloads for music checked off, so I don't know what is causing this.

This is very annoying. Does anyone know how to fix this?

2

I found an answer that doesn't require you stay logged out of the iTunes store (found here, whose poster found it here).

  • In iTunes, press command1 or click Menubar/View/Music.
  • Click the Playlist button from the center-top row of the the iTunes window, below the large Apple logo.
  • Click Menubar/View/Only Music Available Offline.
  • Repeat for all other media types: command2 or Menubar/View/Movies, command3 or Menubar/View/TV Shows, etc.
  • Return to Music Playlists, and the iCloud Download column is gone, no matter whether you're signed into the Store, no matter whether you've enabled/disabled Apple brand subscription-based streaming, and even after quit/relaunch of iTunes.
| improve this answer | |
1

Make sure you log out of the store after you've used it. Go to Store > Log Out and this should sort the problem.

| improve this answer | |
  • I really don't want to be logging in and out all the time, but if that's the only solution, then I guess I don't mind. – user3932000 Aug 19 '15 at 23:16
  • I, for one, do mind. – 2540625 Sep 24 '15 at 16:37
-1

I just removed it. And you must deactivate it from music, movies and TV for it to remove it

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .