1

I recently switched service providers and received a new router. My phone and old Windows computer connect fine, but my MacBook freezes (rainbow wheel starts going around forever after about 2 mins of being connected). MacBook connects to Wi-Fi fine at a friend's house. Another answer describes something similar being solved by switching off IPv6. However, System Preferences > Network > Wi-Fi > Advanced > Wi-Fi > TCP/IP > IPv6 is set to Automatically and all other options are greyed out. I tried to switch it off via directly entering command into Terminal, but it stayed set to Automatically.

Any suggestions as to why I cannot turn it off? Mac is running on 10.6.8 Snow Leopard.

  • 1
    What model is your MacBook? Can it be updated past 10.6.8 "Snow Leopard"? – RedEagle2000 Aug 16 '15 at 20:34
  • Can you be more specific than "forever"? Have you waited five minutes? Ten? – D A Vincent Aug 17 '15 at 12:21
  • What is the Terminal command you used? – D A Vincent Aug 17 '15 at 12:35
1

Try turning IPv6 off before connecting to the Wi-Fi.

Turn the AirPort off, go to System Preferences, Network, AirPort, Advanced, TCP/IP, Configure IPv6: Off. Then turn the AirPort on, and everything should work fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .