1

In order to create a GSX (Apple Global Service Exchange) account, I created a custom email address (@hartmanmail.tk) and the same error is occurring.

The email domain provided is not permitted for this request.

I have tried to restart the process, use a more common email address (gmail, aol, hotmail) and yet nothing is working. Is there something else I have to do first?

1

Since GSX is part of the Services that Apple extends to partners that are cleared past the level of support that end users receive, you might want to reach out to your contact at Apple to verify that you can use any AppleID to access the service.

Depending on how you qualify for GSX - you might be restricted to use the AppleID you used for testing / certification or one that matches the company that qualifies to allow you to join the program.

Rather than keep making new accounts - get a hold of support or someone that has guided new users since trying to brute force your way into the system likely will have negative ramifications for your access or come back through your company to you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .