3

I ran OS X 10.7 latest version on my MacBookPro 2011.
Then I installed on an external USB stick 10.10.3 from my running system OS X 10.7.
The installation on the stick was successful.

After testing 10.10 for some minutes I restarted the system, took of the usb-stick and wanted to restart from my internal disk the 10.7 system.
However, now there is the installer and insists on installing 10.10, what I do not want to do.

The disk utility says that my internal disk is not writable and that I cannot modify it.
Starting with an external disk with 10.7 works, but does not allow to reactivate the internal disk.

Recovery with Cmd ⌘ R loads 10.7 via the internet (it therefore still know that the original system is 10.7), but I cannot recover the 10.7 system, since I cannot write to the internal disk.

The internal disk is now Master Boot Record partitioned.
I do not know if it was GUID before or not: At least it worked for three years before.
I have a backup, but since this is 1TB I do not want to load it via a USB 2.0 port.

How can I reactivate my internal disk with 10.7? If reasonable I would change to 10.8 (but not higher) if there is a utility that works with 10.8 only. Any proposal or links to tool to remove the OS X installer and allow me to restart from my internal disk with 10.7?

The output of gpt -r show /dev/disk0:

sudo gpt -r show /dev/disk0 
results in:
       start        size  index  contents
           0           1         MBR
           1           1         
           2  1466246608      1  MBR part 175
  1466246610           1         
  1466246611   487278557      2  MBR part 175

I have a time machine backup.

  • Please add the output of sudo gpt -r show /dev/disk0 and sudo fdisk /dev/disk0 entered in Terminal to your question – klanomath Aug 15 '15 at 9:54
  • What kind of backup do you have? A Time Machine backup? – klanomath Aug 15 '15 at 10:17
  • If you use the same account that you used to ask the question, you don't have to go through review to edit your question. Also, you are able to comment on your question and answers, as well as mark an answer as accepted. – grg Aug 15 '15 at 11:39
  • Sounds like a broken hard drive. – Max Ried Aug 15 '15 at 19:25
2

Something really, really bad happened to your internal 1 TB drive:

The GUID partition table was somehow replaced by a dual (and therefore additionally false) MBR partition table.

You may recover the previous GUID and your missing volume with a disk recovery tool like Disk Warrior to some extent. But since you have a backup just restore it:

  • In case you have a Time Machine backup:

    • Boot to Internet Recovery Mode by pressing altcmdR. The prerequisites for an Internet Recovery are listed here: Recovery/Internet Recovery. In a few words you need the latest firmware update installed, either ethernet or WLAN (WPA/WPA2) and a router with DHCP activated for a successful internet recovery.
      On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot into the Recovery Netboot image which is loaded from an Apple server.

      (Alternatively you may boot to an external drive containing a Recovery HD or a full OS X system or a OS X thumb drive.)

    • Open "Disk Utility" and partition your internal disk: GUID partition scheme (use the "Options..." button at the bottom of the main pane for this), one partition, journaled HFS+.
    • Close "Disk Utility".
    • Attach your Time Machine backup drive.
    • Open "Restore from Time Machine Backup" and restore your main drive if you have booted from a Recovery drive.
      If you've booted from a full OS X external drive just open Time Machine and restore your internal drive.
  • In case you have a different back-up app:

    • Follow the instructions of the non-Apple back-up application

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .