2

This issue happens to me in both my rMBP 13 and my Mac Pro. As I understand it, Little Snitch is not applying the rules when the network filter is off:

enter image description here

But why does it turn itself off from time to time? I always have manually to restart the filter.

2

That's its demo behaviour, it will run for 3 hours then switch off.

Check it thinks it's authorised.
'Open Little Snitch Preferences...'
Registration tab

enter image description here

Also, as you are running it on 2 computers, ensure you have a separate Registration for each [or a Family License] otherwise if it sees 'itself' on the network it will switch off.

You are correct in your assumption that it is not applying the Rules when the Network Filter is off.

| improve this answer | |
  • A thorough response, thanks. I do have it registered with a single license on each computer: i.imgur.com/VVy3f3y.png I checked everything else. Now that you mention it, I think this started when I installed it on the mac pro. Must be a licensing problem. – Carles Alcolea Aug 15 '15 at 10:23
  • The pricing makes it cheaper to get the Family License even for just 2 machines; so I'd go for that, if that's what it turns out to be. – Tetsujin Aug 15 '15 at 10:36
  • That keyboard shortcut doesn't toggle the Network Monitor in terms of limiting traffic—it toggles that display window into view. Also, just to be clear, the Network Monitor is different from the Network Filter which is the functional portion of the app responsible for filtering traffic. The Network Monitor merely displays traffic and what activity is allowed through (and which isn't). – Art Geigel Mar 8 at 3:19
  • 1
    @ArtGeigel - all I can say is "D'oh!!" I've been using LS since v1 & I never spotted that, thanks. – Tetsujin Mar 8 at 9:25
  • All good :-) Just wanted the clarification in place for all who happened upon the topic in the future. I came here looking for a CLI way to enable/disable the filter and have requested at least 10+ times that Objective Develop provide a way to add a shortcut/hotkey to toggle this. Sometimes I need the filter off! Haha. – Art Geigel Mar 9 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .