15

On my Macbook Pro (Retina, Mid 2012) is a process, called PTPCamera, using a lot of CPU-Time . I already have killed this process but it spawned immediately again.

85% of CPU usage eats my Battery so I would be happy if anyone could help 😊

I found out that the process is a "Picture Transfer Process for a Camera" in Short PTPCamera it will be launched by iPhoto.app and also with the newer Photo.app. But still does not explain the high CPU usage without a Phone connected.

So what is this process for and how can I control its behaviour? Anyone else has this problem and how did you solve this?

  • What build/version of OSX? – bmike Aug 17 '15 at 19:37
  • @bmike happened on my 10.10.4 (14E46) Productive Machine with iOS9 Public Beta, did not happened (yet) on 10.11 ElCap. – bMalum Aug 18 '15 at 5:28
18

So we found the Solution:

  1. Connect your iPhone/Camera and reopen Photos.app or iPhoto
  2. Close iPhoto or Photos.app
  3. Disconnect your iPhone/Camera
  4. Open Photos/iPhoto again

now the PTPCamera Process should be terminated gracefully and won't spawn again in a busy waiting loop.

You do not have to do this steps all the time, only necessary to terminate the process graceful and kick it out of the busy waiting state. How to come in this state, we (AppleDev and I) do not know.

  • 1
    Worked for me on 10.7 Lion as well. – D A Vincent Jul 4 '16 at 4:18
1

I've just noticed the same issue with the public beta of El Capitan build 15A243d when connecting an iPad 3 to charge and have reported it to Apple.

In my case I had neither iTunes or Photos open and also selected the iPad to "Not Trust" the computer as I want only wanting to charge the iPad. So this appears to be a bug. Hopefully this will be fixed in a later build.

Force quitting the process for now.

  • Welcome to Ask Different! If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – Jaime Santa Cruz Aug 17 '15 at 18:27
  • How much CPU does it consume on your machine - does it spawn immediately again? – bMalum Aug 18 '15 at 5:29
0

When it happened to me and I opened iPhoto, I found it iPhoto tried to show the pictures in my iPad, but failed to do so. So it seems to be related to a temporary failure of retrieving the photos

I closed iPhoto, unlocked iPad, unplugged and replugged in the iPad, and everything was fine (PTPCamera peacefully stayed at 0% CPU usage). I doubt it was related to the iPad unlock, but am not completely sure. It could be fixed by the replugging.

-3

I would just force quit the process, and if that doesn't work, I'd make a command line script to constantly send the "kill" command.

  • This process is needed for iPhoto, however. – Spotlight Aug 15 '15 at 1:34
  • Well this does not solve the problem - only the symptom. – bMalum Aug 15 '15 at 8:16
  • Wouldn't repeat of the killings prod says have the potential to correct the iOS device and or the photos database? Seems like a sledgehammer for when a flyswatter is required – bmike Aug 17 '15 at 19:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .