0

Today I've been looking for deleted by mistake folder. Time machine should help me, right? But when I entered time machine (after multiple errors saying "Can't connect to a current Time Machine backup disk."), I saw my backups in light red, which means it's now available and nobody knows why (thanks Yosemite):

enter image description here

What to do? How to recover this backups?

1

After hours of investigation, I've found the solution. Just run Finder as root:

sudo /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

And under this Finder you should be able to Enter Time Machine and browse lost backups.
I hope somebody will find this useful.

1

Your question & solution both would suggest there's some kind of permissions issue on the drive - essentially it doesn't think it 'belongs' to your account.

If you've recently changed machines, or migrated there's a chance it still considers the old machine to be owner [even if the account names are the same]

Try Get Info on the drive & see what it says.
You might see something like this -

enter image description here

Click the lock & authorise if you need to make changes.

"Fetching" is a user from an old machine who wasn't migrated to this machine.

Also not that this drive has both staff & admin groups. staff would be added by the system as the generic group permission, admin is an ACL. Alternatively, the group could be the same name as your user name, but starting with an underscore. e.g. fred (Me) & _fred
This is, in effect, a group containing only (Me).

Ignore ownership is the 'quick' way to solve issues, but may not be available on a Time Machine drive, so

If you want to strip the permissions down to basics, then you need
fred (Me) - Read & Write
staff - Read & Write
everyone - Read only

When set, then use the 'gear' icon to 'Apply to enclosed items...'

enter image description here

9
  • My drive preferences shows me 4 groups: (me) RW, system RW, wheel RW, everyone R. – orkenstein Aug 15 '15 at 15:47
  • & are you a member of the wheel group? You wouldn't be by default, you would have to add yourself manually. My TM drive is predominantly system-rw staff-r everyone-r ..except for the top level which is me-rw staff-rw everyone-r. I'd check further down the hierarchy. – Tetsujin Aug 16 '15 at 8:43
  • No, and I have no idea why this group appeared. Some info: superuser.com/questions/191955/what-is-the-wheel-user-in-os-x – orkenstein Aug 16 '15 at 11:42
  • I think the simplest might be to see what groups you're in id myname in terminal, make sure admin & staff are in that list, add them if not ... sudo dscl . append /Groups/theGroup GroupMembership myname [needs password] .. theGroup is admin, staff or wheel Add yourself to wheel anyway, if you're already in the other 2. Relog to enable the changes. – Tetsujin Aug 16 '15 at 12:01
  • 1
    Applying "My user" RW permissions to Backups.backupdb helps too. Thanks! – orkenstein Aug 16 '15 at 12:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .