0

I want to use set clipboard="unnamedplus" in my vim, which requires X11 feature.

But I searched a bit on google.
Which only mentions that Apple has removed X11 from their recently releases of OSX. But there is no tutorial about how to install it on OSX.
Especially no info about how to enable X11 feature in a vim on OSX.

How to do that?

1

You are correct that Apple no longer provides X11 in OS X. They now recommend you download and install XQuartz instead. Recent versions of OS X will actually prompt you to install XQuartz when they detect you're trying to run an application that requires X11, but the detection isn't foolproof so sometimes you just have to install it manually.

Not sure about your vim question specifically, but I would guess if you run vim in an xterm after you've installed XQuartz, any X11 features should work as intended.

2
  • No, I ran a terminal from XQuartz, vim X11 feature is still off. Which is sad. – Zen Aug 14 '15 at 10:33
  • @Zen Hmm. If it's the built-in version of vim you're using, I wonder if it just hasn't been compiled with X11 support... X11 was never meant to be an integral part of the OS X experience. In which case, you might try installing vim from somewhere like the fink project to see if that supports the options you want. – calum_b Aug 14 '15 at 10:39
0

Have you considered completely bypassing X11 and using MacVIM instead? If the purpose is to have the VIM GUI instead of text mode in a terminal and have access to the Mac's clipboard, this is probably the better way to go. However, if you're looking to use the clipboard while remotely connecting to another UNIX box, that is a different story.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .