1

While using my iCloud account to receive emails, i've structured it to filter the content down to an organized fashion according to my liking.

So lets say I have :

Inbox
VIP
Drafts
Sent
Archive
Trash

All those are set up normally, and when using a native app like Apples Mail, this all populates properly.

Now I've gone and created numerous folders with rules in iCloud.com so all my devices sync to these folders instead of me having to manually do it for every device/mac.

For example I have:

Folders    +
   Family
   Friends
   Coworkers

The rules i have set from iCloud.com for those folders are pretty straight forward, i.e., "Move messages from example-person@gmail.com to Family folder" etc etc

This all works as it should. No issues there. But I don't receive any new email nofications, and its certainly not pushed to my phone when they are sorted to these folders. The only way I know if I received anything is I have to click on the specific account in the iOS mail app, then navigate to each folder for them to update. I don't get banner alerts, or badges/sounds. I have to manually check for new messages for each folder in iCloud.

I've verified my 'Fetch New Data' setting was set to Push for all accounts as I want my emails immediately and it is set to so. I've also selected the sub folders in the said iCloud account, and ensured they are selected for Push as well, and they are. Still no notifications or badges.

Any suggestions for course of action?

  • Hmmm do you know what triggers the notification in the "normal" case? If it's a rule in Apple's incoming mail handlers it wouldn't trigger on an IMAP folder event. Don't know if that's even possible with the iCloud rules. I assume you're only using your Apple based email account, right? – rholmes Aug 16 '15 at 23:10
  • No I am not. I have multiple accounts @rholmes do I know? Yes. What I mentioned above. Setting the fetch rate and ensuring the folders I want pushed are selected. How do I know it works? Because it works for my iPad. But for some reason I feel like I'm overlooking some setting or something somewhere. – soulshined Aug 16 '15 at 23:13
  • Yeah sounds like a good use case - my setup isn't quite so advanced so I don't think I can help but it's an interesting question- surprised no one is looking at it. +1 – rholmes Aug 16 '15 at 23:15
  • Yeah me too. Any help is appreciated though @rholmes thanks for trying – soulshined Aug 16 '15 at 23:17
  • was your low power mode on? Also check by sending two dummy mails from another device, one that should go right into inbox and other to say family. Also, go to iPhone mail settings-> notifications-> iCloud and enable all. – ankii Aug 21 at 11:09

You must log in to answer this question.

Browse other questions tagged .