10

I want to type in macron (e.g. ā) in my OS X, but after I searched for how to type in it, I got that I first must use U.S. Extended Keyboard as suggested in this article.

However, once I switch to U.S. Extended Keyboard, I cannot type in å any more with ⇧+a and a, because on U.S. Extended Keyboard, it provides you with the aforementioned macron letter.

So is it possible to type in macron with normal English keyboard on OS X?

3
  • Are you currently using Yosemite, or which OS?
    – bjbk
    Aug 13, 2015 at 13:22
  • @bjbk Yosemite, but I'm able to switch to El Capitan immediately if it's possible there.
    – Blaszard
    Aug 13, 2015 at 13:23
  • Possibility "Alt+Maj+," to create "¯", and add in Shortcut "¯a" to create the "ā" (and so on for each letter). Possibly, any shortcut could be fine, but this one seems legit since it create a kind of macron.
    – Larme
    Aug 13, 2015 at 15:18

2 Answers 2

5

Keep US Extended and use it to type your å. It's alt + k and then a.

7
  • 2
    The OP wanted to know if there's a way to avoid using the U.S. Extended keyboard.
    – jvriesem
    Aug 13, 2016 at 19:24
  • Does U.S. Extended Keyboard exist anymore? I can only find ABC - Keyboard. Also, typing alt (option?) + k results in ˚a. Jan 3, 2019 at 20:11
  • 1
    @NobleUplift abc extended is just the new name for us extended which Apple decided to use a while ago. Jan 3, 2019 at 23:36
  • @NobleUplift Typing option shift k in ABC Extended should produce Combining RIng Above. You type it after the base character, e.g ẘ. All this is described at sites.psu.edu/symbolcodes/mac/codemacext Jan 4, 2019 at 14:34
  • Returns ˚a on my mac. Mar 6, 2020 at 18:20
18

This is just a option without changing the default Keyboard.

In OS X, this can be accomplished by holding down the A briefly and a pop-up will appear.

Select diacritic

Just select by clicking or typing the corresponding number. In this case 8

ā ← Like that

The repeat delay can be set to prevent eeeeeeeeee from happening too quickly.

Keyboard settings

7
  • 1
    If I hold down a it returns aaaaaaaaaaaaaaaaaa... because I set defaults write -g ApplePressAndHoldEnabled -bool false, but I don't like to get back. Thanks for your answer though.
    – Blaszard
    Aug 13, 2015 at 13:32
  • 1
    I apologize. I was thinking of others who may have had similar problems typing other diacritics that stumble across this question. Your answer was the correct and accepted answer. It was perfect, I was merely elaborating. I'll remove it.
    – bjbk
    Aug 14, 2015 at 17:15
  • 3
    Your answer is in fact the correct answer for most users. It just so happens this poster has purposefully disabled the Character Picker, which is not normal. His question ideally should have said that... Aug 14, 2015 at 19:27
  • I agree. That fact didn't come to light until mentioned in comments. :/
    – bjbk
    Aug 14, 2015 at 19:30
  • 2
    His answer do not help the original question asker, but helped other people who searched for solution. Many thanks! Jun 20, 2022 at 9:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .