5

On Yosemite (Mac OS X 10.10.4) I'm not able use the shortcut Command-Shift-B, while Command-Shift-<another-letter> works as expected.

I've double checked this in the Keyboard Viewer: pressing Shift, Command and B simultaneously won't show the B button as pressed.

That is, this is what I see when pressing the 3 buttons:

enter image description here

Same goes by pressing Shift-Command and then clicking the B in the Keyboard Viewer with the mouse pointer.

Is there any setting that might prevent the B from getting pressed?

8
  • Which app is in the foreground? Finder? Are you using any bluetooth devices? If enabled shift-cmd-B means: send file to bluetooth device (like your keyboard or mouse ;-))
    – klanomath
    Aug 12, 2015 at 18:52
  • Thanks, I forgot to note I had removed the shortcut of the "Send File To Bluetooth Device" service in the keyboard preferences. The problem here is I'm not even able to type the B with those 2 keys though, independently from the app.
    – mindrones
    Aug 12, 2015 at 19:01
  • Does this happen with all combinations of the left/right command and shift keys?
    – Kent
    Aug 12, 2015 at 19:51
  • Yes, with all combinations
    – mindrones
    Aug 12, 2015 at 20:13
  • It would work depending what app is in front. For example open Firefox and use the shortcut and it will open the Bookmarks. In others which do not have it, it will sound a system alert.
    – Ruskes
    Aug 12, 2015 at 20:34

2 Answers 2

9

If you have ClipMenu installed, the default key bind for the snippets menu is CMD+Shift+B.

To get this shortcut working in other programs, you'll need to either disable the shortcut or change it to another combination in ClipMenu Preferences:

ClipMenu Preferences

1
  • 1
    Such a life saver. The fork Clippy has the same problem. May 8, 2018 at 18:51
0

I am unaware of a setting that would prevent the B from being pressed when modified by + Shift. Assuming that you are not running any third party applications that may be affecting/altering keyboard shortcuts, such as Keyboard Maestro, I suggest you try the following:

Delete (move to trash and empty trash) the file com.apple.symbolichotkeys.plist from /Users/YourName/Library/Preferences and restart.

1
  • Thanks, I've tried but it doesn't work.
    – mindrones
    Aug 12, 2015 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .