1

I've got a MacBook Pro (Retina, Mid 2012), once in a longer period of time my MagSafe 2 adapter simply fries. Just a minute ago I fried the third MagSafe 2 adapter in three years time. It occurs with a click-sound like something small and fragile broke, right after that the charging LED turns off and it's dead.

Is there anything that I should check with my MacBook? Or is there something else I could attempt to try? Since I'm not really in the mood to fry another MagSafe 2 adapter.

Edit: I've also tried resetting SMC and even tried sitting on it to warm it up as suggested in this article.

Edit: Also ran a Apple Hardware Test which returned 4sns/1/40000001:IDOR-0.000 which seems to basically mean "No power connected". Not of much use.

  • 2
    FWIW, I had the 2012 MBA and have not seen this happen. Assuming you are using Apple adapters, you should be able to contact Apple support because this should not be happening. You might be able to negotiate this to be covered under the original warranty because you've killed 3. – Alan Shutko Aug 12 '15 at 18:28
  • are the pins fried? dark ? – Ruskes Aug 12 '15 at 23:02
  • Hi @Buscar웃, nope, they look fine. Also checked if they're stuck, which does not seem to be the case. – Ambidex Aug 13 '15 at 6:35

You must log in to answer this question.

Browse other questions tagged .