0

My mac keeps randomly crashing. I could be just browsing the internet with no other programs running and it would just crash. It literally just crashed while in the middle of this... Second time today.

Crash reports in order.

Tue Aug 11 15:13:43 2015

* Panic Report *

panic(cpu 2 caller 0xffffff80301fef12): "Possible memory corruption: pmap_pv_remove(0xffffff8045f9a860,0x19c9c785b000,0x40f27, 0x8000000040f27066, 0xffffff80e1b7bbf4, 0xfffffebf007392d8): null pv_list!"@/SourceCache/xnu/xnu-2782.20.48/osfmk/i386/pmap_internal.h:768
Backtrace (CPU 2), Frame : Return Address

0xffffff80e1b7bab0 : 0xffffff803012bda1 
0xffffff80e1b7bb30 : 0xffffff80301fef12 
0xffffff80e1b7bc20 : 0xffffff80301ff645 
0xffffff80e1b7bc80 : 0xffffff80301ad505 
0xffffff80e1b7bd90 : 0xffffff80301a319c 
0xffffff80e1b7bdc0 : 0xffffff803014e637 
0xffffff80e1b7be00 : 0xffffff80305c1d49 
0xffffff80e1b7be70 : 0xffffff80305d9572 
0xffffff80e1b7bef0 : 0xffffff80305d9a47 
0xffffff80e1b7bf30 : 0xffffff80301282d6 
0xffffff80e1b7bf60 : 0xffffff803021843e 
0xffffff80e1b7bf80 : 0xffffff8030234b3f 

BSD process name corresponding to current thread: Google Chrome He

Mac OS version:
14D136

Kernel version:
Darwin Kernel Version 14.3.0: Mon Mar 23 11:59:05 PDT 2015; root:xnu-2782.20.48~5/RELEASE_X86_64
Kernel UUID: 4B3A11F4-77AA-3D27-A22D-81A1BC5B504D
Kernel slide:     0x000000002fe00000
Kernel text base: 0xffffff8030000000
__HIB  text base: 0xffffff802ff00000
System model name: MacBookPro9,2 (Mac-6F01561E16C75D06)

System uptime in nanoseconds: 127346294634689
last loaded kext at 123209043165477: com.apple.filesystems.smbfs    3.0.1 (addr 0xffffff7fb2a5e000, size 389120)
last unloaded kext at 124152739916206: com.apple.filesystems.cd9660 1.4.4 (addr 0xffffff7fb29f1000, size 32768)
loaded kexts:



Model: MacBookPro9,2, BootROM MBP91.00D3.B08, 2 processors, Intel Core i5, 2.5 GHz, 4 GB, SMC 2.2f44
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1600 MHz, 0x802C, 0x384A54463235363634485A2D3147364D3120
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1600 MHz, 0x802C, 0x384A54463235363634485A2D3147364D3120
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (7.15.166.24.3)
Bluetooth: Version 4.3.4f4 15601, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Samsung SSD 840 EVO 250GB, 250.06 GB
Serial ATA Device: OPTIARC DVD RW AD-5970H
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: IR Receiver
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

Crash #2

Tue Aug 11 17:20:12 2015

* Panic Report *

panic(cpu 0 caller 0xffffff8009c17cc2): Kernel trap at 0xffffff800990e27e, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0xffffff812b7ee8b8, CR3: 0x00000001256a30bf, CR4: 0x00000000001626e0
RAX: 0x000000001176eec5, RBX: 0xffffff807450e400, RCX: 0xffffff807450e800, RDX: 0x0200030000030000
RSP: 0xffffff809cc93bc0, RBP: 0xffffff809cc93c30, RSI: 0xffffff807450e000, RDI: 0x000000003e0b3994
R8:  0xffffff833a259938, R9:  0xffffff812b7ee8b8, R10: 0xffffff8123ae6844, R11: 0xffffff807450e800
R12: 0xfffffea4e0628000, R13: 0xffffff807450effe, R14: 0xffffff8019ae72d0, R15: 0x000000000c001a35
RFL: 0x0000000000010202, RIP: 0xffffff800990e27e, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0xffffff812b7ee8b8, Error code: 0x0000000000000000, Fault CPU: 0x0

Backtrace (CPU 0), Frame : Return Address
0xffffff809cc93870 : 0xffffff8009b2bda1 
0xffffff809cc938f0 : 0xffffff8009c17cc2 
0xffffff809cc93ab0 : 0xffffff8009c34b73 
0xffffff809cc93ad0 : 0xffffff800990e27e 
0xffffff809cc93c30 : 0xffffff8009b8f4e1 
0xffffff809cc93ca0 : 0xffffff8009b8dff5 
0xffffff809cc93cd0 : 0xffffff8009b90591 
0xffffff809cc93d10 : 0xffffff8009b996ff 
0xffffff809cc93f20 : 0xffffff8009c18224 
0xffffff809cc93fb0 : 0xffffff8009c34a85 

BSD process name corresponding to current thread: Google Drive

Mac OS version:
14D136

Kernel version:
Darwin Kernel Version 14.3.0: Mon Mar 23 11:59:05 PDT 2015; root:xnu-2782.20.48~5/RELEASE_X86_64
Kernel UUID: 4B3A11F4-77AA-3D27-A22D-81A1BC5B504D
Kernel slide:     0x0000000009800000
Kernel text base: 0xffffff8009a00000
__HIB  text base: 0xffffff8009900000
System model name: MacBookPro9,2 (Mac-6F01561E16C75D06)

System uptime in nanoseconds: 6500848118676
last loaded kext at 7538807461: com.apple.filesystems.autofs    3.0 (addr 0xffffff7f8ba92000, size 45056)
last unloaded kext at 101422304842: com.apple.driver.AirPort.Brcm4331   800.20.24 (addr 0xffffff7f8b74f000, size 2043904)
loaded kexts:

Please help me try to fix this!

  • The crashes happen sporadically and I'll have to just wait and see when the next one will happen. I am updating my ram to 16gb because I will be using a lot of editing software and I'll need the extra speed in order to process it all. Thanks for all the suggestions. I will be trying every suggestion until it no longer crashes on me and I will be updating this page to keep you guys informed. I have already updated to 10.10.4 and re checked the ram ports. It wasn't a big deal. I've taken macbooks apart in the past, so I know my way around. – Steven Aug 11 '15 at 23:52
1

I recommend you install the OS X 10.10.4 Update as it contains a significant number of fixes, especially in networking and wireless.

After that:

  • Does it crash if you boot into Safe Mode by holding down the Shift key immediately after startup?
  • Does it still crash if you create a new user and log in with that account?
  • Have you booted into Recovery Mode and used Disk Utility to repair your startup disk and repair permissions on your Mac's partition?
  • Have you installed any custom fonts into Font Book or by dragging into the Fonts folder of either Library folders? Have you tried running

atsutil databases -remove

  • Have you installed any Chrome extensions, and if so, have you tried disabling them?
  • Do either Safari or Firefox have any issues connecting to and rendering websites? Does Chrome seem to crash on any specific websites, or completely randomly regardless of the site? Do you often work with a large number of tabs open?
  • Have you tried removing Google Chrome and its preferences in ~/Library/Application Support/Google/Chrome/ then installing a new .app from the latest download? You might also find AppZapper useful.
  • In order: I only have one account and never log off; No; I have installed custom fonts. How do I run that command its telling me this on the terminal "You must run as root, use sudo in order to remove system user databases Removing: /private/var/folders/hd/nxtck33d2mn8dj697thjzwd00000gn/C/com.apple.FontRegistry"; Yes I chrome extensions. I will try the guys idea below and remove chrome related apps and reinstall.; I don't use safari or firefox and I don't usually have a lot of tabs open.;I will try that next.; I've never had any issues with the previous version I hate Yosemite... – Steven Aug 11 '15 at 23:48
  • Sorry, should've remembered that -remove requires sudo first: sudo atsutil databases -remove and then enter your administrator account's password when prompted. – da4 Aug 12 '15 at 14:56
  • FWIW I'm not a very big of Yosemite either, but El Capitan looks really promising already. – da4 Aug 12 '15 at 14:56
0

Those logs show it was Google drive and Google Chrome creating the problem.

I would say nothing physically wrong with your RAM hardware, since both panic reports point to Google.

BSD process name corresponding to current thread: Google Drive
BSD process name corresponding to current thread: Google Chrome He

Maybe you reinstall Google Drive (or disable it) and also reinstall Google Chrome, or try different browser.

0

2012 Macbook Pros have known issues with their video chipset causing the computer to restart, show distorted video and no output onto an external display. This is caused by a faulty nVidia chipset used by Apple.

https://www.apple.com/au/support/macbookpro-videoissues/

Not sure if they still offer this, but they were offering to replace the motherboard for a long time, however, you should book a genius appointment to see if you are affected. Unfortunately, they don't seem to replace the chipset with something that works, so your computer will most likely still have this problem in the months after it is fixed by Apple.

-2

The first thing I would check would be the RAM, either swap it out for known working memory or just re-seat it.

  • I would never advise to test memory this way: at random, and with a physical access wich may cause more damages (ESD) than fixes. Rather use a program to test it surely which will show you where the error is: memtestosx.org . – daniel Azuelos Aug 11 '15 at 22:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .