2

I am connected with my iPhone 6 / iOS 9.0 to an IPv6 network created following this article. When I take a look at the console of my device, I see

Aug 11 12:15:07 titos-iPhone kernel[0] <Notice>: 076991.368570 wlan0.N[15305] checkIPv4AddressValidity@6178: Local IPv4  address 169.254.199.45
Aug 11 12:15:07 titos-iPhone kernel[0] <Notice>: 076991.369991 wlan0.A[15306] receivedIPv4Address@1524: Received address 169.254.199.45, entering powersave mode 2
Aug 11 12:15:07 titos-iPhone kernel[0] <Notice>: 076991.370023 wlan0.A[15307] receivedIPv6Address@1547: Received IPv6 addresses 20:1:0:0:0:0:0:0c:4:1:d6:67:90:6f:98
Aug 11 12:15:07 titos-iPhone kernel[0] <Notice>: 076991.370032 wlan0.A[15308] receivedIPv6Address@1547: Received IPv6 addresses 20:1:0:0:0:0:0:011:71:3f:2:43:17:32:dd
Aug 11 12:15:07 titos-iPhone kernel[0] <Notice>: 076991.370042 wlan0.N[15309] startRoamScan@5689:5689 starting RoamScan; MultiAPEnv:0 isdualBand:1 isOn5G:0

Why do I see Received address 169.254.199.45 when I'm actually trying to connect to an IPv6 network?

How can I disable this behaviour and only receive an IPv6 address?

1

169.254.199.45 belongs to Zeroconf. This does not necessarily mean, that any IPv4 outgoing connection can be made or will be made. See https://en.wikipedia.org/wiki/Link-local_address and http://www.zeroconf.org/ (maintained by an Apple employee)

  • This doesn't really answer his question which is basically how can I turn off IPv4, it just explains what that IP address is. – Steve Chambers Aug 12 '15 at 16:20
  • ZeroConf is mandatory with iOS and ZeroConf requires IPv4, see the RFC on zeroconf.org. User seems not to know that the IPv4 address in question is a ZeroConf link-local address and has nothing to do with IPv4 upstream connectivity. – Roland Aug 13 '15 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .