0

I recently cleared my history from Google Chrome because of stupid MacKeeper ads, whenever I try to click on any site the new window bars open which was MacKeeper or another ad.
I was sick of it and cleared my history and unfortunately when I reopen my Chrome all my bookmarks have gone. I am so disappointed. I searched everywhere and tried everything but still I am getting these ads and no bookmarks have come back.
They said
"Here's where the Chrome bookmarks and the backup are located:
Macintosh HD/Users/your user name/Library/Application Support/Google/Chrome/Default/Bookmarks"

I tried to reach there but I didn't find any folder of Chrome or Google in my apps even Chrome is installed in my Mac and working fine.
Please, can any one help me out! I didn't backup been ages :'(. I hope it is stored here some where.
Using Macbook Pro Yosemite

1

Try this to see if you're just looking in the wrong place...

Quit Chrome
Switch to Finder
Open a new Finder window, Cmd ⌘ N
Go To... Cmd ⌘ Shift ⇧ G
Copy/paste this ~/Library/Application Support/Google/Chrome/Default/ (including the tilde ~) into that Go To window
Hit Enter

What do you see?

Bookmarks ought to be in there, along with Bookmarks.bak
Hold Alt ⌥ & drag both to the desktop, for safety.
Delete Bookmarks.
Rename Bookmarks.bak to Bookmarks
Launch Chrome

BTW, ~ (tilde) is Mac shorthand for your home folder, in My hard drive/my user name/ without needing to know what they are called. It always goes to your home folder.

  • I tried this, where it put this ~?? – Simi Aug 11 '15 at 11:10
  • where what puts what? – Tetsujin Aug 11 '15 at 11:10
  • I tried to put Tilde ~ at the beginning nothing happened and then tried at the end nothing happened as well. No any new window opened! Even with out tilde~ nothing happened! :( – Simi Aug 11 '15 at 11:13
  • just copy/paste, don't try to type it by hand. Something will always happen, even if it's an error. If you get an error, post it exactly as written. – Tetsujin Aug 11 '15 at 11:14
  • sorry, I left the tilde out of my copy/paste line, my bad. Fixed – Tetsujin Aug 11 '15 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .