0

I am trying to add a Windows printer through the advanced option:

enter image description here

but, as you can see, the Type and Device lists are both inactivated. What is happening here?

4
  • While not sure why your advanced window is showing (sure isn't for my print prompt), you can add the printers in the IP or Windows tabs. Have you tried adding your printer through there? If this question is more how to fix the advanced page to display properly, you should consider rewriting the question to clarify.
    – smoooosher
    Commented Aug 10, 2015 at 16:08
  • I need to add the printer via smb://..., so IP is not an option.
    – qed
    Commented Aug 10, 2015 at 19:40
  • 1
    if you do smb://server.local/printername in the URL field does that fail? Commented Aug 11, 2015 at 0:20
  • You can try adding it in through the CUPS interface then - to enable CUPS web interface, launch terminal and type cupsctl WebInterface=yes - then launch safari and go to localhost:631/admin and hit Add Printer. You'll see the spoolss service available towards the bottom of the list and can add an SMB printer through there
    – smoooosher
    Commented Aug 11, 2015 at 16:08

0

You must log in to answer this question.

Browse other questions tagged .