I have a 2013 MacBook Pro with a 500GB SDD. It has been backed up on a regular basis to two different external disks - one is a 4TB Thunderbolt HDD, the other a 4TB WD Black drive connected via a USB 3.0 Thermaltek dock.

I have purchased a new (2015) MacBook Pro with a 1TB SSD, and wanted to migrate my 2 years worth of configuration, customization, apps, and data files. Everything I have tried has been a complete and utter failure, and I cannot figure what I have done wrong. At the end of each round, I rebooted the 2015 Macbook Pro, went into Internet Recovery, wiped the disk and reinstalled OS X Yosemite. This took about 2 hours to complete each time.

Round 1: First, I attempted to do Migration Assistant from the Thunderbolt HDD to the new Macbook Pro. Everything seemed to go well enough, until the "Transferring your Applications folder" screen got down to 3 minutes. At that point, it began to climb...and climb...and climb. After ~72 full hours of Migration Assistant, it was at "128 hours and 54 minutes remaining." I figured, at this point, that something was wrong.

Round 2: I thought perhaps there was something wrong with the Thunderbolt HDD. I plugged it into my 2013 MBP and did verify disk / verify permissions. Everything was reported as OK. I re-connected it to the 2015 MBP and started Migration Assistant again. After ~48 hours of Migration Assistant, it was at "63 hours and 12 minutes remaining", and again was only going up - never came down at all once it started climbing.

Round 3: OK, there must be something wrong with the Thunderbolt drive. Verified the external USB caddy drive, everything checks out OK on it. It's been a few days, so I do one last Time Machine to the USB drive to make sure it's the latest and greatest going over to my new machine. Same symptom - around 5-10 minutes remaining, the number starts going up into the stratosphere. Trying to be patient, I again give it 70+ hours..."106 hours and 49 minutes remaining." (As an interesting side note, I checked several times in the last few hours and each time found it interesting that the external drive was NOT spinning at all...)

Round 4: OK, something is wrong with the Time Machine setup. Screw it, let's go machine to machine. Connect 2013 MBP to 2015 MBP over Thunderbolt, start Migration Assistant on both. They refuse to see each other. Fine. Let's try Ethernet.

Round 5: Buy a 1GB Ethernet switch to isolate the two machines, and plug in each using Cat 6e that has been successfully tested to route at least 923Mbps. After ~24 hours and "18 hours and 26 minutes remaining," I give up.

Round 6: Back to Thunderbolt. This time, we'll put the 2013 MBP in Target Disk Mode. OK, they see each other fine, now. ~24 hours, "19 hours and 9 minutes remaining." #$()$%$()!!!!

Round 7: Maybe it's the 2015 MBP. Go to my 2013 iMac, put it in Migration Assistant mode, put the 2013 MBP in "Target Disk Mode" via Thunderbolt cable. Everything connects. ~24 hours, "16 hours and 33 minutes remaining."

At this point, I have spent nearly two full weeks trying to do ANY kind of migration using Apple's "Migration Assistant", and it has been nothing but failure after failure after failure. I could repeat all these experiments with the iMac and the various devices, but a sneaking suspicion has started to form in the back of my mind. So I wipe both the iMac and the 2015 MBP; I do a bare minimum setup of Yosemite on the 2015 MBP, creating just my user account and installing Google Chrome, letting it sync my bookmarks and such. I connect them via Thunderbolt, boot the 2015 MBP in Target Disk Mode, and do Migration Assistant on the (now completely clean) iMac.

It has been 13 hours. Migration Assistant says "6 hours and 43 minutes remaining."

Things that have been checked:

  • Verify Disk
  • Verify Permissions
  • No OS X updates available for any of the three machines
  • All cables used have been tested in other use-cases and worked fine (saved files, copied files from one computer to the other, etc.)

Is this tool just completely broken, or am I missing something? Is there some kind of "debug mode" I can put it into where I can see what it is hanging on? Is there a different tool that anyone can recommend that would allow me to perform this kind of migration?

  • In case the rate of increase means anything to anyone, in the 10 minutes since I made this post, "6 hours and 43 minutes" became "7 hours and 51 minutes."
    – TML
    Commented Aug 10, 2015 at 5:03
  • 1
    This is a common problem with Migration Assistant especially if you run some kind of dev environment with a myriad of files. Why don't you just clone the drives with carbon copy cloner. I'd expect it to take less than an hour if the 500 GB drive is filled completely.
    – klanomath
    Commented Aug 10, 2015 at 5:37
  • I will give this product a try. Thank you, @klanomath.
    – TML
    Commented Aug 10, 2015 at 5:53

5 Answers 5


Ok I just got a new MBPr 15 and had this problem too. Fresh migration didn't work. If I skipped migrating and used migration assistant later that did work but isnt really a full copy.

Here is what worked for me. Boot up the new computer into recover mode. So boot and hold 'r'. In recovery mode try using restore from time machine backup. That took maybe 2 hours but worked.

  • I will give this a shot, thanks for the suggestion.
    – TML
    Commented Aug 10, 2015 at 12:02
  • Your welcome. It was really annoying me too. I'm glad I figured out how to get past the issue. Commented Aug 12, 2015 at 6:17

Ok, I have actually had this problem a lot as I'm the IT guy at a company that uses Macs and I could never figure out what it was but just found the answer: it's the Thunderbolt Bridge

On the computer you're migrating from, plug the Thunderbolt cable in. Then go to System Preferences>Network and make sure that there is a network interface called Thunderbolt Bridge. If there isn't, hit the plus sign in the lower left corner and add one.

Now, go into Migration Assistant or Target Disk mode on that machine and go into Migration Assistant on the new machine. The new machine should find the old disk and be able to migrate appropriately.


When having problems with Migration Assistant the first thing to do is go back to basics.

Do the migration one step at a time. When I run into trouble I create a new user on the old machine and migrate just that user.

I then make sure I clean as much junk out of my account on the old machine. Then try migrating just that account. If you get problems with that then empty out the Documents and Music folder (which is usually where most of the size lives) and try once again. That usually works.

Then, and only then, try migrating the Applications.

  • My question was an absolute wall of text, so I completely understand if you didn't read the entire thing. However, I did mention in my question trying "a bare minimum setup of Yosemite on the 2015 MBP, creating just my user account and installing Google Chrome, letting it sync my bookmarks and such" as having the same exact symptoms. Certainly I could just delete Chrome and try that, but if Migration Assistant can't transfer even that much, is it at all usable? Regarless, thanks for the suggestions.
    – TML
    Commented Aug 10, 2015 at 5:48
  • No, turn off everything in Migration Assistant so that only the bare minimum is taken from the old computer. If you then do it a step at a time you should get a different result. Commented Aug 10, 2015 at 5:53
  • My "test scenario" for Migration Assistant in this case is that the "Old Computer" is a completely fresh install of OS X with a single user who has only Google Chrome installed. There are no Documents or any other data. Then I perform "Migration Assistant" to migrate the user. It is currently telling me that it will take 9 hours and 27 minutes to complete such a migration.
    – TML
    Commented Aug 10, 2015 at 6:04

I found that turning off WiFi on both machines did the trick; using Thunderbolt cable


I had no luck with Migration Assistant either.

My early 2011 MBP 15" video system recently failed (https://www.apple.com/support/macbookpro-videoissues/) which requires motherboard replacement by Apple. It wouldn't boot but the HDD was good, but unfortunately I didn't have an up-to-date backup. I had a local Mac repair shop pull the HDD and back it up to a brand-new USB3 external HDD.

My company issued me a new 2015 MBP 13" and I wanted to use Migration Assistant to restore my apps, data, configuration, etc. from the external HDD to the new MBP. Migration Assistant sees the data I want to restore on the external drive, all 371GB of it. But shortly after clicking "continue" on the Migration Assistant screen with the checkboxes for data categories, and amount of data per category, I get a message "Migration quit unexpectedly". No further information. External HDD is connected to new MBP via USB3. Same OS version (El Capitan) on old and new machines. Tried it several times, after cold reboot, with wifi off, etc. Always the same result.

Migration Assistant appears not useful, and I'm facing manual migration of data, re-installation and configuration of applications, etc. (https://support.apple.com/en-us/HT202910). Affords a chance for some clean-up and reorganization, but also a big time sink.

  • That sucks, sorry to hear that. A few other answers seem to have been posted, have you tried any of them?
    – JMY1000
    Commented Feb 25, 2016 at 6:56
  • JMY1000 - unfortunately the other answers don't apply to my situation because they all assume a functional Mac to migrate from. The Mac I wanted to migrate from wouldn't boot. I haven't lost any data; I have all the data I want on an external HDD, organized how Migration Assistant expects it (Migration Assistant can see the data). But Migration Assistant quits unexpectedly. I am having to manually migrate data from the external HDD and reinstall / reconfigure apps.
    – Randy
    Commented Feb 25, 2016 at 15:55
  • What about virtualizing OS X and booting the virtual machine from the external HDD?
    – JMY1000
    Commented Feb 25, 2016 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .