5

I am using OS X Yosemite 10.10.4 at my office. Last week, I was still able to right click files or folders and choose services from the bottom of contextual menu. However, after I started my Mac this morning and reopen the Finder, I am not able to see the services submenu after right click. I can only choose the services without using the columns view and click Finder > Services from the top left.

I typed this command in the Terminial but it did not solve it:

/System/Library/CoreServices/pbs

Is there another other way to make it what it was? Thanks.

enter image description here

Edit: After rebooting, the problem still exist, but I noticed one thing: the services shows up only on desktop, but not within the finder window.

Edit 2: In addition to desktop, it also appears in icon view, but not in column & list view (which previously do).

I have also tried quiting/force quiting Automator Runner, ScriptMonitor and some other background processes which was not responding from the Activity Monitor, but still no good.

enter image description here

Edit 3: After some observation, it might be caused by the Adobe CS5 / Creative Cloud / Finder conflict. I have uninstalled CC which I don't use much (needed to share with other people). Will observe some more time to see if it is completely resolved.

  • sorry, should have waited for it :) – Ruskes Aug 10 '15 at 2:52
  • Nah, it okay :) – Pete C. Aug 10 '15 at 2:52
  • so the "Reveal in Finder" is missing – Ruskes Aug 10 '15 at 2:53
  • Yes, and some custom services I created, like copy path and delete files permanently... I use them all the time. – Pete C. Aug 10 '15 at 2:57
  • Without those custom services, my workflow would take more time. I can add shortcuts to them, but the most annoying part being not working in the columns view (it perceive the selected folder as opened folder...) It's just weird that something worked for a long time suddenly not working. – Pete C. Aug 10 '15 at 3:10
3

Later it was accompanied with the Spinning Beach Ball of Death. After uninstalling Adobe Creative Cloud it does resolved all problems.

3

I experienced the exact same bug! I found out, that i was logged out of Creative Cloud. When I logged back in, the Services-menu appeared again in Finder. This is a very weird bug..

  • Good to know it! I post it here just in case someone experience it too. :) – Pete C. Sep 4 '15 at 4:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .