1

I am not able to get my MacBook Air to resolve any hosts.

I've tried reinstalling Yosemite from recovery, unloading and reloading the mDNSResponder to no avail. An nslookup of www.google.com using 8.8.8.8 resolves correctly. I've tried different WiFi networks and disabling and re-enabling the WiFi. I don't know what else to try. I did an ifconfig and it did not show any name severs

  • which (other) DNS are you using or just 8.8.8.8 or 8.8.4.4 ? – Ruskes Aug 10 '15 at 0:47
  • I hadn't configured any but it looks like adding 8.8.8.8 to my list of dns servers fixed the issue – richbai90 Aug 10 '15 at 0:49
1

Usually it is recommended to use public DNS servers like Google 8.8.8.8 and 8.8.4.4 in situation like this.

You can delete any other DNS in your syst pref Networks- DNS or make sure the Google is at the top of the list.

If you want to get in to the DNS then use a little app called namebench which will analyze and recommend to you the best (fastest) DNS server. I have used the namebench and followed its recommendation and yes, my loading of the web pages is faster.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .