2

Just got a new Macbook, my first Mac in 5 years, and I'm having trouble getting it to save my Wifi network information. If I remember correctly, I was able to connect to the network at the office with no trouble, but when I try to connect to my home network, I get the error in the title: A keychain could not be found to store "<network name>".

I then get the option to Cancel or Reset to Defaults. When I select Cancel, it connects just fine, but won't reconnect if I leave the house and return, or shut wifi off and turn it back on. If I select Reset to Defaults, a dialog box pops up asking for my login password, but I can't type in the box. I click on the text box, but typing does nothing.

  • Well it appears like you don't have a login keychain. Open Keychain Access, how many do you see? You should have at least three Login, System, System Root, and iCloud (optional). – user14492 Aug 9 '15 at 1:14
  • 1
    I have 4: login, Local Items, System, and System Roots – Ryan Aug 9 '15 at 3:14
  • Keychain Access > Preferences > First Aid > Set Login Keychain as Default and Keep login Keychain Unlocked On? If that doesn't help Keychain First Aid (⌥⌘A), repair. Still problems, Preferences > Reset Default Keychain. You can the just move old items into newly created keychain. – user14492 Aug 9 '15 at 10:39
  • Already tried resetting the default keychain, and the login keychain is already the default. No problems detected with Keychain First Aid. – Ryan Aug 9 '15 at 18:27
  • I've got exactly the same issue, tried everything and just did what worked for you BUT, still got the 'A keychain could not be found to store...' after connecting. Did you do anything else that could have contributed to making it work? Do you have multiple accounts that can login? Thanks – JonnyT Aug 12 '15 at 19:14
8

The issue was resolved by removing the network from the list of Preferred Networks: System Preferences --> Network Preferences --> Advanced --> Find network and click "-" to remove from list of networks. After that I restarted the computer, and was able to connect and save the network without issue.

  • Restart was required – s g Dec 19 '18 at 17:51
-1

Used Titanium Software's OnyX utility to repair system files permissions, now this issue is resolved for me.

-2

A reboot seemed to do the trick for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .