0

When i run memtest86 or memtest86+ on my MacBook Pro 8,3 2011 17" 2,5GHz the machine reboots after a few seconds. I tried 3 different pairs of ram modules. problem persists. I never had any issues running memtest86(+) software on various Macs.

I wonder if this problem is related to this MacBook model in general or if there's some something wrong with the machine. (Yes it already has the new Logicboard)

5
  • What version of memtest86+ are you using? It needs to be v5.01 to handle "Sandy Bridge" CPU's, which is what the MacBook Pro (17-inch, Late 2011) has. – user3439894 Aug 8 '15 at 13:47
  • Memtest86+ V5.01 (27/09/2013) – benjaminvonderweiden Aug 8 '15 at 16:13
  • Can you run your copy of memtest86+ on a different system that has a "Sandy Bridge" CPU' just as a kind of test to see if it runs okay or not? That is what I'd do if hitting the same wall you've described so as to eliminate my copy and device it's running from as part of the issue. In other words you need to know whether or not the tools and methods can be validated on a known good working system for comparison and validation that the tools and methods you're working with are not at fault with the results you're currently getting on your MBP (17", Late 2011). Process of elimination. :) – user3439894 Aug 8 '15 at 16:23
  • when i put the same cd into my macbook pro 15" mid 2012 memtest runs without a problem – benjaminvonderweiden Aug 8 '15 at 22:07
  • Assuming the RAM you're trying to test on the MacBook Pro (17-inch, Late 2011) is of supported type then can you test the RAM you're trying to put into the MacBook Pro (17-inch, Late 2011) on another system to rule out the RAM as being at fault? I think that's what you're going to have to do and if the RAM checks out on another system then you'll have to look at other hardware on the MacBook Pro (17-inch, Late 2011) that may be causing the issue. – user3439894 Aug 9 '15 at 1:02
0

I had the same weird behavior on a 17" Macbook Pro (Late 2011). So this is probably not a sign of trouble. I wanted to be sure that the memory was actually OK, and I remembered that there are two versions of memtest86: memtest86 (by PassMark, memtest86.com) and memtest86+ (GPL from memtest86.org)

The Passmark versions seems to have more active development at the moment. I gave it a try, and it actually works on the MBP 17"! Be sure to boot in in EFI mode, otherwise an older version of it will start which exhibits the same reboot behavior as the memtest86.org version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .