1

I am unable to update any of my apps on my iPad Air and can not add a new app. When I try to update I get a spinning circle. There has been no error notice. Any idea what the problem is?

1
  • Do you have free space on the device? Have you tried restarting?
    – orkoden
    Dec 7, 2015 at 16:27

1 Answer 1

-1

That happened to me with my iPad Air. I solved it by backing my iPad up to iTunes and then deleting the app from my iPad through iTunes, then I clicked Apply. I then downloaded the app from the App Store again. This will delete any data the app has on your iPad.

YMMV, as a few months later this app (Pages) was doing the same thing again, so I put it off and put it off and I never fixed it again, but when I updated to the iOS 9 Public Beta on my iPad the app was fixed! So you might just wait a couple of months until iOS 9 comes out and the update should hopefully fix the app for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .