1

I am re-writing my question to make it simpler to understand. I am using OSX 10.10 version and I need to connect with SAMBA share server.

Now when I open the finder application and press command +K and enter the server address as smb://serveraddress/sharename I am able to connect with SAMBA sever and shared drive.

But when I remove the shared drive name (i.e. smb://serveraddress/), I am not able to connect with SAMBA server.

Please suggest what can be the possible reasons for this problem. Is it mandatory to provide shared drive name if I have to connect with SAMBA share.


[Older version of question] I am using stunnel as client in my Mac machine to connect with SAMBA share.

I am using below stunnel configuration in my mac machine. accept=127.0.0.1:119 connect=target server information

I am able to start stunnel service and its getting bound also with my destination server.

Now when I try to open the remote server directory with root folder(smb://127.0.0.1:119/) , this does not work and my connection getting closed after entering the credentials. However if I specify a shared folder name(smb://127.0.0.1:119/folderName) then this does work and my shared drive get open in my machine. I am facing this problem in Mac OS 10.10. However, I am able to achieve same functionality in my windows machine using stunnel connection. Please let me know if someone has faced similar issue in Mac OS with stunnel connection or have any idea about possible cause of the problem. Kindly help

  • 1
    are the IPs you give just for example or the actual ones you use? Are you sure you have the IPs correct? – Deesbek Aug 7 '15 at 14:03
  • Yes I am binding stunnel on localhost on port 119. I also tried using virtual network interface (tuntaposx.sourceforge.net) to bind stunnel on some other ip but that also not worked. – sahas Aug 7 '15 at 15:06
1

At the university I work at, I ran into the issue with Mac users where they could connect to a SMB share folder within a shared directory, but not the root of the drive until I set the user permissions on the share's root to at least RO for the credentials they used to connect. Are you sure that you have the correct user and share permissions set on the root to connect at that level?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .