1

I have iPhone 3GS jailbroken running some version of iOS4.

With the latest iTunes version 12.2.1 (and the previous one I had installed), the device is not recognized as plugged in. Windows sees the device just fine.

  • I've tried restarting the device.
  • I've tried restarting the computer.
  • I've updated to latest iTunes.
  • Bonjour and the "Apple Mobile Device Service" (sp?) are running.

Is it not recognized because it's jailbroken? Or are there other things I can try before restoring to non-jailbroken version?

Edit:
- Tried clean reinstall of iTunes 10.7 and 9.2.1 (edit 3: and 8.2.1)
- Tried different USB port

Still no luck. Windows sees the device, but iTunes does not.

Edit 2:
- Tried different cable
- Tried on a different PC
- Tried on a different Mac

2

The latest iTunes does not support as much older versions of iOS as iOS4 is.

I recommend you to uninstall your current iTunes, clear cache ... etc., reboot your computer and then download and install an older version of iTunes.

Once you are done with the above steps, I can recommend you to make sure that the USB port on your computer works well and to check the USB cable of the phone as well. Last thing that I can suggest is to have your iPhone unlocked and follow up if anything occurs on it's display.

Let us know if any additional information is needed.

  • What version of iTunes would I need to support iOS4? – Slav Aug 6 '15 at 17:46
  • iPhone 3GS could use iOS versions between 3.0 and 6.1.6. As of it's said in Wikipedia about iOS 6 (en.wikipedia.org/wiki/IOS_6) An update to iTunes version 10.7, which was released on September 12, 2012 is necessary to install the iOS 6 update on a device. – Anton Todorov Aug 6 '15 at 17:54
  • Tried iTunes 10, 9 and 8. going through Apple's lengthy uninstall process every time support.apple.com/en-ca/HT204275. Tried using a different USB port too, but I liked I said before, the port/cable are fine, since I can use the device through windows (for viewing files) just fine – Slav Aug 9 '15 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .