1

I'm trying to reset my keychain (Yosemite 10.10.4).

  • When I enter my wifi password I get "A keychain cannot be found to store my_wifi_sid"
  • I click "Reset to Defaults"
  • I get "Are you sure you want to reset your keychain? This will delete all your saved passwords, keys, and certificates. You cannot undo this operation" and click "Reset"
  • I get "Please enter your login password. This password will be used to create your new keychain." with a password field. Attempts to type in this field interact with whatever app is in the background (browser, desktop). I can click the "Show password" checkbox.

This issue has also been reported at https://discussions.apple.com/thread/6788761. Upgrades did not help.

Deleting keychain folders via the command line ends up with the same result (not saving passwords and the above dialog). This started about a month ago and does not appear to be associated with any system update.

Any tips on troubleshooting, logs to look at would be appreciated.

Update

tl;dr: disabling the Guest User and upgrading to El Capitan seems to have done the trick.

Not what I'd call an answer since I can't tell you which action is the fix, but here are two things, one or both of which may have solved my problem.

I tried to log into the Guest User on this machine and learned that somehow I got a not-managed Guest User account. This Guest User was asking for a password (which I did not know). So I disabled the Guest User account.

Disabling the Guest User account seemed to solve this issue for some (but not all) of the users. Next I downloaded the El Capitan installer to a thumb drive and installed it on my MacbookPro. Now all of my keychain issues appear to be fixed.

  • What does the Wifi password has to do with keychain ? – Ruskes Aug 6 '15 at 1:53
  • @Buscar웃 I am asked to re-enter my wifi password every time I log in. So the fact that it is a wifi password may be inconsequential aside from the fact that this is something that Yosemite tries (unsuccessfully) to store in the keychain. – eebbesen Aug 6 '15 at 3:06
-2

I had the same problem. Following the steps in this article helped me resolve my issue:

  1. Open Keychain using Spotlight (⌘-Space)
  2. Go to Keychain Access → Preferences
  3. Click Reset My Default Keychain
  4. Restart your Mac

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Thank you @jack. That did not work for me though. – eebbesen Aug 8 '15 at 21:27
  • Links rot. Please include the relevant information behind in the link in your answer. – Ian C. Aug 9 '15 at 2:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .