0

This is a strange one & only seems to affect text entry [questions, answers & comments] on SE sites. I've not really noticed it anywhere else, but this is where I do most of my web-site typing.

As I start to type into a text field, all is well, but the longer I type, the slower the input gets, until eventually I can be half a sentence in front of what's appearing on screen. [It's doing it now, as I type this question]

First thoughts would be RAM/paging, CPU busy, overall computer speed - however, I have 64GB RAM, about 12GB in use, swap is 0 bytes; CPU is doing about 2% right now; machine is a Mac Pro 5,1 3.46GHz 12-core.

I've tested using a completely clean admin account, in case of any legacy prefs/extension issues etc [as this is a migration from an older machine], with the same results, typing lag after just 2 or 3 lines of text.

This also used to happen on my old machine, Mac Pro 3,1 2.8GHz 8-core, so it's not machine-specific.

I just discovered it doesn't appear to affect Chrome, so I'm suspecting Safari itself more than anything else.

I've tried disabling all Edit > Spelling & Grammar and all Substitutions with no improvement.

OS X 10.10.4 Safari 8.0.7 - though it's not been exclusive to those versions, it is getting worse over time.

I'd appreciate any further troubleshooting ideas, or even just confirmation that anyone else may have seen this behaviour.

  • Just a thought — might Yosemite 10.10.5/Safari 8.0.8 make a difference? – aaplmath Aug 22 '15 at 18:55
  • If only ;-) ...but no, hasn't made any difference, been on it a week now :( If it didn't affect other accounts too, I'd suspect some extension/plugin/login item, but it affects all accounts, even fresh ones & root. – Tetsujin Aug 22 '15 at 19:24
0

I guess we should mark this one down as
"El Capitan & Safari 9 fixed it"

I no longer see anything like the 'lag' I was getting before & all behaves as it should.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .