7

For starters here is my current setup:

I have an iPhone 5s and a MacBook Pro 13" mid 2012 model with OSX 10.10.4. Recently I changed the storage to an SSD and with that change I started to set up iMessage. At first iMessage worked for a decent period of time I was getting texts on time and sending them through my Mac just fine. About a week ago suddenly I couldn't send any messages without getting the "Not Delivered" and that red exclamation mark. Going through pages of forums many of the problems were either a year old or older and were very repetitive. It was either delete some files through Keychain Access, restart something or turn on the message forwarding.

Update: After playing around I realized that I can send messages to some of my contacts. These contacts are people who don't have this red highlight on their names and if they do have their name highlighted in red then I cannot send messages to them.

Update2: After looking through imessage on my mac I realized that all the contacts that I cannot send to have usually been sent through text not imessage since their text bubbles are green. The ones I can send to are blue.

I just want to know how to fix my current problem.

  • Welcome to Ask Different! What did you try from the forums? – Jaime Santa Cruz Aug 4 '15 at 16:23
  • I tried deleting some files using keychain access, I restarted imessage and my mac, I tried to update (but I had the latest version), I signed out of my imessage and I tried quitting this task on activity monitor – Kevin Aug 4 '15 at 17:35
5

What you are trying to do is send SMS messages from Messages on your Mac to people without iOS devices, correct? (Just fixed this for my wife this morning.)

Be sure to add your Mac to your iPhone's Text Message Forwarding.

On your iPhone:

  • Go to Settings
  • Messages then select Text Message Forwarding
  • There you will see a list of devices that use your Apple ID for Messages
  • Add your MacBook if listed.
  • Enter the code displayed on your Mac into the iPhone dialog when prompted.

Now you should be able to text from your Mac using Messages.

Apple support documentation for further reading.

Screenshot of Message settings

  • Where is the "Text Message Forwarding" thing on my iphone? I have an iMessage slider. I think I have already done this step too btw :/ – Kevin Aug 4 '15 at 18:19
  • You must have iOS 8 or higher installed. Under the Settings. See my answer and the link for details. – bjbk Aug 4 '15 at 18:20
  • I have the most up to date software on my mac and iphone – Kevin Aug 4 '15 at 18:31
  • Also here is what I did on my iphone. settings>Messages and then all I see is an iMessage slider at the top, then a "Send Read Receipts" then a "Send As SMS" then a "Send & Recieve" multiple option where inside I placed my apple ID and I could be reached by imessage through my phone number and my email. Then there is a bunch of "SMS/MMS" options at the bottom. There is no "Text Mesage Forwarding" thing there :/ – Kevin Aug 4 '15 at 18:34
  • I just added a screenshot. Compare that if it helps. This will not show up unless the other devices are using the same Apple ID in Messages. Cheers – bjbk Aug 4 '15 at 18:37
1

I'd try signing in and out of iMessage on your Mac to see if that helps.

  • How to you sign out of imessage? there is no sign out button. If it meant deactivating and reactivating my access then I had already done that – Kevin Aug 4 '15 at 16:52
  • To sign out, get into Messages, then in the menu click Messages->Preferences->Sign Out. Sign out should be by your Apple ID. – RedEagle2000 Aug 4 '15 at 16:54
0

I had the same problem and was able to solve it.

You won't see "Text Message Forwarding" until you do this step first on the latest iOS.

  1. Go to Settings => Messages => Send & Receive
  2. Tap "Use Your Apple ID For iMessage"
  3. Input your Apple ID and Password then Sign In.
  4. Go back to Messages
  5. Tap Text Message Forwarding
  6. Select your Mac or other devices you want to use to allow them to send messages using your phone.

Then it shoud send SMS messages successfully from your Mac to your iPhone. =)

0

In the macOS Messages app, go to Preferences > Accounts, and check to ensure the iMessage account is logged in and active.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .