I enrolled to Apple's beta program as I want to test some software under El Capitan. Therefore, I would like to instal El Capitan in Virtual Box.

Is there a recommended way of doing this? As I understand I have to install Yosemite first and then upgrade to El Capitan beta?

I understand, that I have to convert the .app I download into a bootable image which I can use to install it in a virtual machine - can somebody point me to a reliable (tested) howto how I can do this?

  • Do you have any version of OS X running within virtual box?
    – bmike
    Commented Aug 12, 2015 at 17:21
  • Hi there! Unfortunately, installing a Mac OS onto a virtual box is in violation of their Use Policy and would violate the rules of Ask Different. You would have to at least install the OS onto a physical Mac (non-virtualized) for us to begin helping answer.
    – smoooosher
    Commented Aug 12, 2015 at 17:24
  • 13
    @smoooosher Actually Apple's SLA allows you to virtualize OSX on Apple hardware, so as long as the host is a Mac, it's allowed. "you are granted a [...] license: [...] to install, use and run up to two (2) additional copies or instances of the Apple Software within virtual operating system environments on each Mac Computer you own or control that is already running the Apple Software, for purposes of: (a) software development; (b) testing during software development; (c) using OS X Server; or (d) personal, non-commercial use." Commented Aug 12, 2015 at 17:29
  • Let's open a thread on Ask Different Meta to discuss the on or off topic status -- it's a bit complicated for comments IMO
    – bmike
    Commented Aug 12, 2015 at 17:43
  • @onik Only if the license for the OS was obtained through the Mac App Store. Single-Use installs and/or preinstalled applications grant one installation on one instance of Mac hardware. I'm pretty sure El Capitan hasn't hit the App Store yet ;) I also do not see anything in Sec. 15 of the Beta Software License that grants an exception to the Virtualization rule.
    – smoooosher
    Commented Aug 12, 2015 at 18:08

5 Answers 5


The instructions below, found in Creating a bootable El Capitan ISO image, worked for me after a download of OS X El Capitan from the App Store.

hdiutil attach "/Applications/Install OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
hdiutil create -o ElCapitan3.cdr -size 7316m -layout SPUD -fs HFS+J
hdiutil attach ElCapitan3.cdr.dmg -noverify -nobrowse -mountpoint /Volumes/iso
asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/iso -noprompt -noverify -erase
rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
cp -rp /Volumes/esd/Packages /Volumes/OS\ X\ Base\ System/System/Installation
cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System/
cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/OS\ X\ Base\ System/
hdiutil detach /Volumes/esd
hdiutil detach /Volumes/OS\ X\ Base\ System
hdiutil convert ElCapitan3.cdr.dmg -format UDTO -o ElCapitan3.iso
mv ElCapitan3.iso.cdr ElCapitan3.iso

Additionally for running within VirtualBox:

  • Create a new OS X El Capitan from Wizard.
  • Change "System->chipset" to PIIX3, mount created ISO and boot up.
  • If you only see a the CD/DVD as installation target within the installation program choose "Utilities > Disk Utility" and erase the VirtualBox disk, which will lead to an empty HFS+ Journaled disk, which now could be chosen as target.
  • 1
    When formatting be sure to pick "GUID Partition Table". Commented Dec 4, 2015 at 4:08
  • I tried following the instructions above on "Create a Bootable" however, the ISO image file does not work. I get the following error in virtualbox 5.0 Failed to open the disk image file /mounted_drive/ElCapitan3.cdr.dmg. Could not get the storage format of the medium '/mounted_drive/ElCapitan3.cdr.dmg' (VERR_NOT_SUPPORTED). Result Code: VBOX_E_IPRT_ERROR (0x80BB0005) Component: MediumWrap Interface: IMedium {4afe423b-43e0-e9d0-82e8-ceb307940dda} Callee: IVirtualBox {0169423f-46b4-cde9-91af-1e9d5b6cd945} Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) Any ideas ?
    – USTD
    Commented May 8, 2016 at 0:05
  • 1
    @user1556435 Under OS X 10.11.4, the manual page for cp says "Historic versions of the cp utility had a -r option… however, its use is strongly discouraged, as it does not correctly copy special files, symbolic links, or fifo's." Did you mean to use -r or is it a typo and you mean -R (recursive)? (My manual page doesn't actually say what -r did, just that it wasn't very good at it.)
    – Calrion
    Commented May 27, 2016 at 1:05
  • 1
    @Calrion I think the built in man page for OSX is trying to imply that -r was another way to do a recursive copy that didn't support those options. If you google "manpage cp" one of the first results notes that: -R, -r, --recursive copy directories recursively. So I would think it would be a safe bet to use -R if you like. Commented Jun 6, 2016 at 14:58
  • 1
    A warning for those trying to follow these instructions: You must be running El Capitan (or, presumably, higher once Sierra comes out) in order for them to work. If you're running a Yosemite host (as I am) then these instructions (suitably modified) will work to create a Mavericks or Yosemite boot disk, but you cannot use them to create a working El Capitan boot disk (the VM will hang during the boot process and never get to the installer). Also, the created iso can't be used to upgrade a Yosemite VM (you'll get an error message when you try). For that, you need to use the App Store. Commented Sep 12, 2016 at 2:23

VirtualBox appears to have support for El Capitan. This screen shot is of the dialog for creating a new virtual machine.

Screen shot of VirtualBox option for El Capitan

If you can't find instructions for going from the El Capitan .app to a VirtualBox VM, you may want to follow directions for doing so with Yosemite and hope they work. This guide worked for me.

Update Another idea: Use the above-linked guide to get Yosemite working in VirtualBox, and then upgrade to the beta from within the VM. I just tried this, and it worked for me.

Showing El Cap in a VirtualBox window

Note that VirtualBox doesn’t seem to have any integration software for OS X, so you can't do things like drag to change the guest OS resolution, or enable clipboard sharing, unless I’m really missing something!

  • Thanks! What is your VirtualBox version? Commented Sep 10, 2015 at 20:39
  • Downloading Yosemite from the App Store does not seem to be possible anymore [1] How to proceed? Using the El-Capitan image directly I cannot get past the UEFI shell [1] reddit.com/r/applehelp/comments/3n19d0/… Commented Oct 18, 2015 at 18:54

I was able to follow this tutorial and get El Capitan up and running with only a few snags:

  1. On Step 5 I think there is something wrong with the syntax to remove the broken link, I ended up just opening it in finder and trashed it.
  2. There's a bit of a typo on Step 7, some of the html got stuck in the expression

Besides that it all seems to be working so far :)


There is a new option now which is the easiest: Parallels Light, which is free when running Mac or Linux OS, available from the App Store. Perfect for this type of job.


The high level, brief answer is that you should run the beta software on bare metal for best results. I'm not aware of any virtualization package that supports El Capitan yet (hours after it was announced).

Surely the vendors will update their tools in time, but in general, I don't think VirtualBox has the best support of any OS X as a guest operating system when running on Mac hardware due to it being focused on multiple host OS compatibility as opposed to a Mac centric design.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .