0

Perhaps similar to Command+C (copy) with the left command key does not work, but (left) +c DOES work for me.

They keyboard is an Apple US (with the 10-key), wired. I am using a razer mamba mouse (i only say this because it shows up in the Select Keyboard dropdown that i can set the modifier keys for in the Sys Prefs->Keyboard->Modifier Keys... menu)

I've already tried resetting the default keyboard shortcuts.

Update: I also cannot type a capital W using the left shift

Update: I have tried this with 2 different keyboards, but both are the apple US QERTY [sic] with 10-key. I have tried this on my laptop (rMBP) and on an iMac (both on Yosemite)

Update (with thanks to @bjbk for continued comments/questions): To clarify, I am saying that both systems (2 separate Macs, an rMBP and an iMac [incidentally, both with the drivers for the razer mamba mouse]) exhibit the same behavior described above. The builtin keyboard on the rMBP does not behave this way.

  • 1
    Have you tried a different keyboard? Is this an iMac or MacBook? If a MacBook do the keys work on the built in keyboard. Please edit your question with some facts about your system. Cheers. – bjbk Aug 11 '15 at 14:54
  • sorry, what other sys details might be interesting? – Michael Aug 11 '15 at 18:53
  • 1
    Thanks for the update. So you are saying that you get this behavior on both systems with the external keyboards? That is very odd. Does the built in keyboard on the rMBP behave the same way? – bjbk Aug 11 '15 at 18:56
  • Try uninstalling the mouse drivers on one of the systems. If that makes a difference there is your culprit. Then we can work on why this is the case. – bjbk Aug 12 '15 at 1:27
1

It may very well be that the Razer drivers are incompatable with OS 10.10 Yosemite. According to Razer, it seems the latest driver only supports up to 10.7 Lion although the last modified date on the download site is 26 Mar 2015.

One fix may be to find and get the legacy drivers for your Razer device. However, it may be best just to contact Razer about the issue which may also lead to a solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .