3

My Macbook Pro (late 2013) running OS X 10.10.4 Yosemite, doesn't respond to Hot Corners any more.

Also, if one application is set to full screen, the Finder keeps stuck / doesn't follow if I change (CMD-Tab) the focus to a different application in a different Desktop (Space). I already tried

  • loggin out and in the user account
  • restarting the Finder, OS X
  • repairing rights while starting up from another partition
  • changing hot corners settings, mission control settings
  • deleting the ./Library/Preferences/com.apple.dock.plist
  • resetting the RMC, PRAM
  • I can get back to the main screen / first Desktop with CMD-1 but going back to the full screen application only works with a 4-finger horizontal swipe.
  • I noticed Hot Corners work fine with a test accounts, so it must be something with this account.

I've been at this for hours and running out of ideas. Any thoughts?

Update 151203
Recently, I updated to OS X 10.11.1 El Capitan, but this didn't change things.

Update 160214 Did some tests again and noticed the screensaver can be set as a hot corner function, but other functions can not. Also, (with or without fn) Function keys don't work (only in this user account).

In the System Preferences / Keyboard / Shortcuts I used the [Restore Defaults] button. This made the Dashboard function available via Function keys again, but not via Hot corners.

App Expose also only works via the keyboard and gestures Show Desktop and Mission Control don't work at all.

  • Same problem on my IMac (27-inch, Late 2009) – PluckyDuck Aug 17 '15 at 7:32
  • Having the same problem too – too bad no one has answered! I posted my version of my problem and maybe if someone answers it may help your question. > apple.stackexchange.com/questions/227220/… – MrU Feb 12 '16 at 20:44
  • Well it seems deleting the .plist worked for me to fix the dock/ hot corners again. perhaps you could try again? Just make sure the permissions on the dock.plist file are set to read+write to administrators. Source > discussions.apple.com/message/22421052#22421052 – MrU Feb 13 '16 at 22:26
  • Read the link. Deleted the ./Library/Preferences/com.apple.dock.plist again, but no luck. Then remembered this it is a user account problem, so not very surprising. I should search for it in the 'user' preferences. – laptopleon Feb 14 '16 at 13:26
1

I had tried this last year but then it didn't work. I tried it again and now it did work:

Start terminal and execute the following commands:

  • defaults write com.apple.dock mcx-expose-disabled -bool FALSE (this enables mission control)
  • killall Dock (kill and automatically restart the Dock, this is necessary to get it done)

There is an article about hot corners missing dashboard and mission control.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .