1

I have an external hard-disk with a single Mac OS Extended partition. This disk stopped working a couple of days ago. I tried to repair the external hard drive with disk utility but no luck. The error message is the following:

Error: Disk Utility can’t repair this disk. Back up as many of your files as
possible, reformat the disk, and restore your backed-up files.

The hard drive doesn't appear on the side bar of Finder or on the desktop. On disk utility the hard drive name appears to be on "gray" text than "black" text.

How do I repair it on the terminal? Or how can I back up the external hard drive if I can't even access it normally?

diskutil list: 0: FDisk_partition_scheme *500.1 GB disk2 1: DOS_FAT_32 500.1 GB disk2s1 (That's one disk btw, and I don't know why it's on fat32, I last formatted it on MAC OS Extended Journaled)

Thank you

  • what type of drive? what OS X ? did you try in Safe mode ? – Ruskes Aug 1 '15 at 16:51
  • Please provide the output from the following commands: diskutil list and ls /Volumes – Allan Aug 1 '15 at 16:59
  • 500GB WD Passport, Yosemite, How to go in safe mode? ---- diskutil list: 0: FDisk_partition_scheme *500.1 GB disk2 1: DOS_FAT_32 500.1 GB disk2s1 (That's one disk btw, and I don't know why it's on fat32, I last formatted it on MAC OS Extended Journaled) ----- The disk doesn't appear on the ls /volumes command – Jereh Aug 1 '15 at 17:09
  • Do you have any other 500GB drives or is is the only one? – Allan Aug 1 '15 at 17:51
  • just this one... no other EHDs – Jereh Aug 1 '15 at 17:59
1

You could try to "mount" it via Terminal.

First, make a mount point:

sudo mkdir /Volumes/EXT_HD

Now mount (your device numbers may be different, e.g. /dev/disk2s1 — you can determine what it is as it will the the highest number when you issue the command ‘ls /dev/disk*’):

sudo mount -t msdos /dev/disk3s1 /Volumes/EXT_HD/

It might eventually show up in Devices in Finder.

  • 1
    mount: illegal option -- 1; usage: mount [-dfruvw] [-o options] [-t external_type] special node; mount [-adfruvw] [-t external_type]; mount [-dfruvw] special | node; did i do something wrong? :( ";" are linebreaks – Jereh Aug 1 '15 at 17:36
  • did you use sudo and entered your password ? what disk did you choose? – Ruskes Aug 1 '15 at 17:40
  • yes, sudo and then password... the external hard drive – Jereh Aug 1 '15 at 17:58
1

I ran into a similar situation once before; Yosemite wouldn't read my USB drive formatted FAT32. There is also this posting from Stackexchange: Yosemite cannot mount 64GB FAT32 SD Card and this one from Apple Support. I also found this thread regarding the WD Drives and Fat32 FAT32 Size Limitations?

I decided that the safest thing to do was to back it up under Windows, reformat the drive NTFS and copy everything back over. FAT32 is an old MS-DOS format and what better to read MS-DOS than a Windows machine, right?

Now, as for how it got that way, well, drives can't "change" its format on you. If you remember formatting the drive as something else, then I have to ask "Are you sure that is the same drive?"

  • If you have a lot of files or some over 4GB exFat would be a better choice – Steve Chambers Aug 1 '15 at 18:40
  • Over NTFS? Unlikely. If he only going to use that drive on his Mac then HSF+ (OS X Journaled) is the way to go. If it has to go between PC and Mac, NTFS is the best choice. – Allan Aug 1 '15 at 18:48
  • 1
    @Steve Chambers, I have to disagree as exFAT is by no means a robust filesystem and since it only maintains a single file allocation table it is much more prone to failures then FAT32 is. Personally I'd never use exFAT unless I absolutely had no other choices, including paid ones. I'd rather use a third-party utility on either, or both, Mac and Windows to allow read/write access to a NTFS/HFS+ formatted drive when dealing with files over 4GiB and moving between the two OSes. Just my 2₵ worth. :) – user3439894 Aug 1 '15 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .