Having troubles with a botched system upgrade on OS X 10.10.3, I tried to restore my MacBook Pro, 15" Early 2011 version, using an encrypted Time Machine backup made on an external USB drive.

The backup is in working order; I can boot from it just fine. However, when I try to restore from a previous backup version through the system restore feature, I am asked for my Time Machine backup volume, and when I click the external drive, and enter the password, there's a dialog saying the password is wrong.

But it isn't.

I am a hundred percent certain it's the correct password. It can't be copy-pasted, unfortunately, but I've typed it often enough to know it's correct. And when I finally got to boot the Mac after the – what I thought was – a botched update, I checked my Keychain to verify that the Time Machine password was actually the one I had used previously.

Has this ever happened to anyone, and is there any solution to this, apart from maybe creating an entirely new Time Machine volume and, gasp, not encrypting it?

  • Maybe the problem is a different keyboard layout when on the restore session? Aug 1, 2015 at 15:10
  • No, I checked that in a cleartext window, the layout was as expected. (I also tried swapping y/z keys which I would need for the German layout.)
    – slhck
    Aug 1, 2015 at 18:49
  • I am on the same boat now. Using Sierra and TM disk on my Synology NAS. Trying to load files from TM on my temporary older MBP. Have you solved it somehow? Nov 30, 2017 at 12:27
  • @PetrÚjezdský No, I finally got the Mac to boot again without having to restore it. Never found out what the issue was.
    – slhck
    Nov 30, 2017 at 14:17
  • I have found out that the password it asks for is NOT the backup encryption password but the password for sparsebundle itself. Nevertheless there must be bug, because the given sparsebundle pwd works in the "Data migration wizard" on normally booted OS but not in the wizard after cmd+R. :( Dec 1, 2017 at 15:27

3 Answers 3


I had the same issue happen to me, and in my case, this turned out to be the cause:

I had stored the password in a password manager, and for some reason, a special character had slipped into it. However, this character was not visible in the password manager, neither was it in the keychain! I have no idea when and how that character had slipped into the password.

As a consequence, when copying and pasting it from there, it worked, but when entering it manually, it did not work, because this special character was missing.

I teared my hair until I finally found that out which was only after I had copied and pasted the password into a text editor out of sheer desperation. In this text editor, a symbol was displayed for the non-printable character.

How to fix

I fixed the problem by changing the password of the sparsebundle. To do so

  1. locate the Time Machine sparsebundle (if on a network drive, connect to it first)
  2. open Terminal and enter
hdiutil chpass 
  1. add a space after above command
  2. from Finder, draw the sparsebundle to the Terminal window
  3. hit enter

This allows you to set a new password for the sparsebundle, so you won't have the same problem again in the future. You shouldn't have to enter the current password because it will be taken from your keychain.

I changed the password of all my Time Machine backups.

  • Ah, the good old non breaking space often breaks (no pun intended) things for me, because you can't see it. What password manager was that though? Sounds like a bug to me.
    – slhck
    Dec 27, 2021 at 20:46
  • I was able to identify which character it was in my case. I'm baffled by the fact that it was x'C2' which seems to be a  in most character sets, but it does not display as such. I don't want to blame the password manager, as this character wasn't displayed in the keychain either, so to me it looks more like a system display bug.
    – not2savvy
    Dec 28, 2021 at 11:30
  • Got it, thanks for providing some more details. I hope someone else will find this useful.
    – slhck
    Dec 29, 2021 at 12:10

The same thing just happened to me again after a logic board swap. The backup could not be restored in recovery mode with a message saying that the password was wrong.

However, booting into the regular installation wizard, macOS asks you whether you want to migrate existing data. Choose this option; here you'll find your backup disk. When selecting it, you will be asked for the same password. In the migration wizard, the password works.

This is a serious flaw with the recovery procedure, but Apple Support does not seem to be aware of it.


I would delete the existing keychain entry for your backup and re-enter. It is very possible that you have saved an incorrect value to your keychain.

  • No, that's not what happened. Keychain auto-saved that password after entering it in Finder to mount the drive. There weren't any duplicates either. Guess I'll never find out.
    – slhck
    Oct 16, 2017 at 17:01
  • Don't do that. The keychain entry is probably correct, and once deleted, your last resort has vanished.
    – not2savvy
    Jul 28, 2022 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .