0

For some reason, whenever I try to enable Java in the browser by clicking on the checkbox "Enable Java content in browser" in the Security tab of the Java control panel, it asks for my password and then promptly unselects my selection.

Does anyone know what is happening?

I have OSX 10.10.4. I've also uninstalled and reinstalled the Oracle JRE to no avail.

  • I thought Apple made Java built-in for web browsing – RedEagle2000 Jul 31 '15 at 18:45
  • Yeah, but I thought the Oracle one was supposed to work for that as well? – Opt Jul 31 '15 at 19:32
1

I've got the same issue. Here's how I resolved it using Terminal commands:

  1. Make yourself to root

    sudo su -

  2. Remove the existing JAVA Runtime (JRE) as well as JDK if any

    rm -R /Library/Application\ Support/Oracle/

    rm -R /Library/Oracle/

    rm -R /Library/Java/

    rm -R /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/

    rm -R ~/Library/Application\ Support/Oracle/

  3. Download and install the latest JAVA versions from http://www.oracle.com/technetwork/java/javase/downloads/index.html. You probably need the JRE only. In case local java software stopped working you'd need the JDK too.

  4. Open the System Preferences of OS X, click on JAVA -> Security and activate "Enable Java content in browser"

The setting that prevented you from enabling Java content in your browser most probably is in /Library/Application\ Support/Oracle/.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .