12

TL;DR

I was on ATT for years and could text iPhone and Android users with the iMessage app on my Macs and the Messages app on my iPad. I switched to T-Mobile (and ported over the same phone number) and now I can no longer use iMessage or Messages to text Android users except on my iPhone itself. How can I send and receieve text messages with Android users once again?

Devices that I Own

  • iPhone 6 running iOS 8.4 on T-Mobile Pre Paid with a ported phone number from ATT
  • iPhone 5 running iOS 8.4, but no cell signal. Used as iPod.
  • iPad Air WiFi running iOS 8.4
  • MacBook Pro Late 2013 running Yosemite 10.10.4
  • MacBook Air Mid 2012 running Yosemite 10.10.4

The Longer Story

I was on AT&T for years with multiple iPhones and I was able to use the iMessage app on my Mac laptops and the Messages app on my iPads to send text messages to people who used Android phones. Apple users received texts via the iMessage protocol and those messages showed up across all devices as blue. Android / non-iPhone users in general always used SMS/MMS and texts showed up as green across all devices. I could switch between devices and continue conversations with no problem. All devices were always aware of each conversation as they happened.

I recently switched to T-Mobile and ported over my ATT number. I can no longer use the iMessage program on my Macs nor can I use the Messages app on my iPad / iPod (okay, iPhone 5 with no cell signal) to text message friends that are not themselves Apple iPhone users. I can only text message non-Apple users by directly using my iPhone 6 running iOS Also, all devices are logged in with the same Apple ID.

I'm uncertain if the change of carriers has anything to do with it, but that's the only significnat change that's taken place that I'm aware of, and correlation always implies causation... right? Right.

How can I SMS/MMS non-iPhone people from my iPad / iPod / Macs?

22

On your iPhone, I'd try going into Settings > Messages > Text Message Forwarding and then uncheck the switches by whatever is not receiving SMS messages and then check and then re-authenticate them individually, it should only take a couple of minutes.

  • 5
    I facepalmed so hard I need reconstructive surgery. This was it. The only limiting factor is that for some reason I can't seem to get it to work on my no-service iPhone 5. I see the device on the iPhone 6's Text Message Forwarding option page, but when I try and send a code to the iPhone 5, no such code pops up on the device (which is wifi connected and visible in iCloud). The iPhone 6 just sits there and waits and asks for the code to be input. Oh well, I'm not too worried about that one. – Wesley Jul 31 '15 at 0:39
  • You might try signing out and then back into iMessage on your iPhone 5 (not the iPhone 6). – RedEagle2000 Jul 31 '15 at 0:47
3

I had a similar problem when I changed SIM cards (though I also changed numbers).

To fix the problem I suggest:

  • Signing out of iCloud on your devices and then (starting with your phone) signing back into all of them. This seemed to update my iMessage associated number (which doesn't seem to apply to your situation since you didn't change numbers - so perhaps you can skip this)

  • Ensure that on all your devices iCloud accounts that your email AND (correct) phone number are listed. If your email isn't listed then add it (if your number isn't listed then repeat the above step)

  • On your iPhone 6 go into settings -> messages -> text message forwarding and enable it on all of your devices (that should all be connected to the internet).

  • Enter the relevant codes that pop up on your devices

Note: I think you'd really benefit from updating your iPad Air to iOS 8.whatever instead of trying to get it to work with iOS6

I'm also not sure if you're going to run into problems trying to get it to work on 2 phone devices. I'd try and get it working on all the other devices first and only then try and add your iPhone 5 into your ecosystem.

Helpful sites:

http://www.macrumors.com/2014/11/06/text-messages-phone-calls-on-your-mac/

Hopefully you get it working!

  • Not sure how I missed the typo for the iPad Air iOS version. I'm on 8.4. Also, I followed @RedEagle2000's suggestion and things are workin' on all but the no-service iPhone. I kinda expect that even though I don't have a firm explanation for it. – Wesley Jul 31 '15 at 0:37
  • Yeah, I wouldn't be surprised if there was some clause that doesn't allow text-message-forwarding to phone devices. Good to hear you got it working though! :) – m4p85r Jul 31 '15 at 0:41
2

I had the same issues after I restored my iPhone 6. Going into Settings > Messages > Text message forwarding did the trick.

The only hangup was that the code took about 30 seconds to appear on my Mac's screen. And if you're impatient like I was you cancelled and tried it again some 5 times. So I'd suggest waiting at least 2 minutes before cancelling.

It works, afterall.

  • If "Text Message Forwarding" isn't visible on your phone, toggle iMessage off & on again (you'll need to re-sign-in to your Apple ID) and it will then appear. Well, did for me at least :) – rcoup Jan 7 '16 at 10:11

You must log in to answer this question.

protected by Community Nov 21 '15 at 18:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .