0

Since a couple of days internet connected applications (such as facebook) have stopped working on my wife's iPad mini which has iOS 7.1.2.

Further symptoms:

  • internet works in Safari
  • internet doesn't work in Facebook (though it works with the messenger component), the app store, Dropbox
  • trying to install updates fails (seems to time out, doesn't even start downloading)
  • tried to sign out from the Apple account (Settings -> iTunes & App store) and sign back in, however it won't let me sign in (tried multiple times and confirmed that the account details are correct by signing in on a PC)
  • tried rebooting multiple times to no avail

Any ideas what could be done? I will try to connect it to a PC having iTunes later to see if can help - also will try to update it to iOS 8.4 (hopefully it's possible to do so without being signed in to the apple account).

  • Did you try rebooting the device? (Hold the power button, slide, wait, hold the button again, look at the Apple logo, and then try again?) – DDPWNAGE Jul 30 '15 at 17:48
  • @DDPWNAGE - yes, I did that multiple times to no avail :-( – Grey Panther Jul 30 '15 at 18:35
  • What are you using for Internet? Wi-Fi or cellular data? If you're using Wi-Fi, try switching to a cellular connection. – DDPWNAGE Jul 30 '15 at 19:06
  • @DDPWNAGE - WiFi - the particular model doesn't have cellular data. – Grey Panther Jul 31 '15 at 5:12
0

I solved it - turns out the problem was a flaky internet connection! The clue was that I was unable to sign in to iTunes on my Windows laptop (the connection was timing out), even though I could do the same on my Linux laptop.

I rebooted the router and then was able to sign in to the iCloud account from the iPad and everything started working. I also updated it to iOS 8.4 just in case :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .