2

I have an iPhone 5 with iOS 8.4

Never had an issue untile three days ago.

I went to update some apps from the app store, and it just won't do it. The little circle keeps spinning without ever showing the "stop button" next to the app that also shows the download percentage.

Now I have something like 14 unupdated apps and I can't seem to do anything! I restarted the phone twice but nothing changed.

What to do now?

1

In addition to the answer of DDPWNAGE and user138479 you may try to update directly via the app site and click on "update" there instead of using the "update all" button in the update tab.

Click "App-Store" ➡️ "Updates" ➡️ Click on App Name ➡️ In App Details click on "Update"

Another option might be to check if there is another download hanging which blocks all of the other updates.

Click "App-Store" ➡️ "Updates" ➡️ "Purchased" ➡️ Check if any Apps have a running circle hence an update symbol and stop the update.

One more option is to connect your iPhone with a PC/MAC and switch it off. After that: Press the "Power" and "Home" Button at the same time for exactly 10 seconds. The iphone switches into DFU mode and kills all the running processes. The display is supposed to be black. If the apple logo shows up a second time, youve pressed the buttons too long. After the 10 seconds, release the "Power" button but remain pressing the "Home" button. Your PC/MAC should recognize your iphone and probably install the DFU drivers. After that press the "Power" and "Home" buttons again for another 20 seconds, which causes the iphone to leave the DFU mode and to restart. Try again to update your Apps.

Those are the solutions I was able to find. Unfortunately for me none of them worked, but maybe you'll be successful.

  • thank you and +1 for the effort you put in in this answer! Unfortunately none of them worked :-/ Don't know what to do anymore! :( – Ant Aug 6 '15 at 8:04
  • I just contacted the apple support and they suggested to reset the network settings as well (in addition to user138479's answer). To do that follow these steps: Settings ➡️ General ➡️ Reset ➡️ Network Settings – Daniel Aug 6 '15 at 8:55
  • Update: Apple was not able to solve this problem. Last idea was to recover the iphone. So they suggested the following steps: 1. After resetting the network settings try in a WiFi Network if updating works again. 2. If youre not successfull backup your iphone to the iCloud backup (important: Do not update to your PC/MAC, it has to be the iCloud backup) 3. Restore your iphone 4. Restore your iCloud backup – Daniel Aug 6 '15 at 9:14
1

I had the same problem - not being able to update my apps under IOS 8.4.1. It had always worked before, but seemingly that function just randomly stopped working. Internet access was not the problem. DDPWNAGE's answer worked for me - well kind of. When I went to Settings/iTunes & App Store I didn't find a 'log out' option - instead I had a 'sign in' option! Seems that randomly and unrequested, I had been signed out of iTunes without my knowledge. So I signed in again and everything worked as it should once I had restarted the phone.

0

Try logging out of the App Store and logging back in through your phone's settings.

Click "Settings ➡️ App Store ➡️ Account ➡️ Sign Out," then log back in by typing your iTunes password and click "Log in."

It should work fine after that.

  • It does not, everything is the same. Also, is it normal that the option I have when I click on my account name are "Show apple Id, Logout, iForgot"? – Ant Jul 30 '15 at 17:51
  • I mean, iForgot does not seem like a usual thing for apple to write! – Ant Jul 30 '15 at 17:51
  • @Ant Yes. "Show Apple ID" shows more details about your account. "Logout" logs out. "iForgot" helps you if you forgot your password. – DDPWNAGE Jul 30 '15 at 17:53
  • Okay, cool. Still, I can't update apps! :( – Ant Jul 30 '15 at 17:53
  • 1
    Sometimes turning all the radios off resets connections causing it to work again. Put phone into Airplane mode for several seconds then back on. See if that helps. – bjbk Jul 30 '15 at 19:24
0

I have the same problem with my families 3 ipads (2xair, 1xair2, latest IOs 8.4.1) none of the mentioned solutions worked out for me.

What I found out.

If I deaktivate automatic screen locking. All apps were updates - but with a speed of 1 MB / Minute or even slower.

So, at least I was able to install my sons favorite games ;-)

Hope apple will fix this soon, as we are not alone.

https://discussions.apple.com/thread/7109869?start=45&tstart=0

HW

0

I was having same problem - lots of updates that were stuck on waiting, no updates were hung up in purchases area. And I could not download new apps either, they would stick on the waiting too. I reset all of my settings and I was able to get dowloads working again.

0

I had a similar problem with my iPhone 6 on iOS 8.3. No applications would update, and I could not install new applications either.

Today I found the culprit; the Podcasts application had several episodes in the download queue, but there was apparently a problem with the feed or something. Once I canceled every episode download in the Podcast application, my other applications started updating as normal.

0

I resolved my problem by updating the iOS to the latest (9.3.1) & everything starts updating again. I am also able to download new apps again.

-1

Reset your network config. You'll lose any saved wifi passwords

  • Thanks for your answer. However, a one line answer is not desirable. Perhaps explain to the OP (and future users with a similar problem) how to proceed as you suggest. You may find the How do I write a good answer? section helpful. – bjbk Jul 31 '15 at 1:17
  • why wifi password matters? My iphone can connect to the internet through wifi, it just won't update apps – Ant Jul 31 '15 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .