2

I am looking for a way to see new emails that I received show up in the notification centre. Right now I am following the advice gleamed from this page but when new emails come in all that happens is that I get a notification on my desktop in the upper right corner. However, when I open the notification centre it says "no new notifications". This isn't terribly useful because I want to see all my new emails at a quick glance in the notification centre.

If I am away from my desk I am not going to be able to see all the emails that I missed.

Edit: I am using Safari on OSX 10.9.5

  • Chrome notifications are built in the chrome browser and not retained in the OS x Notification Center. – tron_jones Jul 30 '15 at 18:34
2

I assume you are talking about a Mac with OS X?

To make the Notifications stay till you dismiss them for emails received in Mail.app:

Open the system preferences + Notification.

Click on Mail.

Choose the "Alerts" (not the Banners).

It will stay displayed till you click Close. After that it is no longer in the Notification center.

This is not the same as the original Gmail notifications. To get those:

You need to be signed in to Gmail and have Gmail open in your browser to see desktop notifications. If you want to use that, then you need to use Chrome browser with a extension called "Checker Plus for Gmail ". With that extension you can configure the duration and other stuff.

If you want to filter the Notifications, you can use the mail.app Rules.

For example for Junk mail make a rule to mark it as read, and it wont show in the notifications.

junk

You can play with the Mail-Rules for other emails you do not want to see in the Notification (set them as read).

  • I am using Safari with OS X 10.9.5. I tied my Mail.app to my gmail and I can see notifications showing up in the Notification Centre as you have stated. Unfortunately it isn't ideal since it is showing "Social" and "Promotion" emails in the notifications as well. I realize there probably isn't any real way to fix this :( – fthinker Jul 30 '15 at 19:11
  • Do you know how to set rules in Mail.app ? – Ruskes Jul 30 '15 at 20:03
  • Not sure, but as I understand it the "Social", "Inbox" and "Promotion" tabs in Gmail are purely artificial and Gmail web app specific. They are not imap folders and the emails that end up in those locations don't have any special headers. Correct me if I am wrong. – fthinker Jul 30 '15 at 20:24
  • You are right, if they are not IMAP, they will not be forwarded to your Apple Mail, and not show in your notifications. Make sure you turn off the gmail web notifications, and only use the Apple Notifications as described above. – Ruskes Jul 30 '15 at 20:35
1

On iOS or Mac OS X, use the OS's "Mail" app and enable notifications for it in your settings.

On Android, mail should show up automatically.

On Windows, there is no Notification Center.

It would help if you specified what device/OS you were talking about, and the version of it.

1

In order for Chrome(gmail) mail notifications to stick in the OS X notification UI you will need to associate your mail account with the Mail.app.

The gmail notification that are showing up in the upper right are dependent on the chrome browser and not leveraging apples os.

Once you tie your gmail to the Mail.app, turn on notifications for the mail app account in System preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .