2

I've a late 2008 MBP. It's worked fine up until Monday when the wifi stopped working. It now says "Wi-Fi: No Hardware installed". I've tried looking for it in the system prefs and it's gone.

I've tried reinstalling Yosemite, I've tried resetting pram and smc. No joy. I've repaired disks and permissions.

My bluetooth works as I can stream music to the hifi. The built in camera works too as I can skype, other research has suggested that if these work, it's not a hardware fault.

I've ran a AHT, which came back as no errors. Would it still report error if the airport card/connection doesn't exist?

Has anyone any suggestions before I open her up and poke around?

  • wait, did you say you can Skype call ? that would only work if your wifi is working! – Ruskes Jul 31 '15 at 19:22
  • Do a reset /new install, by opening Network in syst pref and delete the current WiFi profile. Then make a new one and restart. – Ruskes Jul 31 '15 at 19:32
  • Of course I can Skype, when the mbp is connected via Ethernet. – James Porter Aug 1 '15 at 11:12
1

Sounds like it might be a bad Airport card, if you have the tools, open it up and then disconnect and reconnect the antennas connecting to the card. If that doesn't work, remove the card, clean the contacts on the card and then reinstall it. If that doesn't work, you'll need to buy a new card, specific for your model of MacBook Air.

1

It could be just that the Yosemite is not recognizing your Airport card -WiFi function due to the bad setup.

Just to confirm, the Ethernet and Bluetooth are working.

To check, open the About this Mac and look in Networks for information, showing your hardware and drivers and more. If it shows it there do following steps.

Disconnect Ethernet and do following:

To test that, completely remove current WiFi set up, restart and set up new WiFi, restart again and test.

Alternatively start in Safe mode and test for problems with 3d party apps.

Still not working? (use Terminal and copy/paste following)

Manually connect to WiFi

Turn On

networksetup -setairportpower en0 on

Find

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .