Does anyone know if it is possible in iMessage on Mac OSX to set the return key to go to the next line instead of sending the message?

  • 2
    Have you tried Shift+Enter? Are you looking for the key combo to do it, or to replace the return key functionality altogether – smoooosher Jul 29 '15 at 21:18
  • 1
    That didn't work – aseem Jul 29 '15 at 21:21
  • My apologies, I was thinking on the fly. Either Option+Return OR Control+Return will do the trick. – smoooosher Jul 29 '15 at 21:53
  • 1
    This question didn't yet received a correct answer but a workaround. I found a partial answer which looks like a better ergonomic design: apple.stackexchange.com/a/236255/22003 . – dan Apr 27 '16 at 8:39

Press option+return or control+return to enter a new line.

Edit: Added additional key combo re: smoooosher's comment to the OP

  • 3
    I found one more funny workaround: [ctrl]+[Q], [return]. •••• This is a good way to remind the function of [ctrl]+[Q]. – dan Apr 27 '16 at 8:40
  • 1
    @danielAzuelos What does control-Q do? – Tuesday Nov 7 '16 at 20:24
  • @larsmoa, The comment made by daniel Azuelos does indeed work and it's ⌘Q not ^Q that quits an application! – user3439894 Mar 14 '17 at 19:35
  • 1
    Sorry, my bad. I will delete previous comment – larsmoa Mar 15 '17 at 7:53
  • I always forget this because Slack is the opposite. – brandonscript Aug 13 '19 at 18:31

There is no preference available to control that, but I wonder if you could override the event associated with the Enter key? The following command maps the Enter key to a menu item command. You'd just need to replace the command with "insert new line"... somehow.

defaults write com.apple.iChat NSUserKeyEquivalents "{ 'New Message' = '\\U000a'; }"

To undo your change later:

defaults delete com.apple.iChat NSUserKeyEquivalents


  1. http://osxnotes.net/keybindings.html
  2. /System/Library/Frameworks/AppKit.framework/Resources/StandardKeyBinding.dict
  • New Message isn't the function activated by the [return]. •••• The code sent to the application by the [return] is \U000d and not \U000a •••• I didn't find any finished answer along these hints. – dan May 2 '16 at 16:15

Just tried CTRL+Enter and it worked

  • 3
    This is the same as the solution that was posted a year ago July. – tubedogg Nov 8 '16 at 0:48

Holding down "Shift" + "Option" (Left side - not right, it doesn't work on that side for me) will create spacing between paragraphs without sending the msg

Hope this helps


For me the solution in iMessage: alt+Enter

  • 1
    This is the same as the solution that was posted a year ago July. – tubedogg Nov 8 '16 at 0:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .