2

So, as the title says, I have an iMac 21.5-inch Mid 2010 model and I installed Windows 8.1 with Boot Camp. After attempting to uninstall Ubuntu and Windows in Disk Utility (in OS X and Recovery) it would always give me an error, "Partition failed with the error: The requested size change for the target disk or a related disk is too small. Please try a different disk or partition, or make a larger change."

What I have tried:

  1. I have tried resetting PRAM/NVRAM with Command + Option/Alt + P+R, nothing.
  2. I have tried holding X to Start up from an OS X startup volume when the Mac would otherwise start up from a non-OS X startup volume. Using Startup key combinations for Mac, still nothing (did work before).
  3. I have done things in grub rescue such as ls (lists partitions and disks) and attempted to boot back into Ubuntu.
  4. I have tried holding Option/Alt to get into the startup manager, still boots to grub rescue.
  5. I have tried holding Command + R to boot into Recovery, worked before, not working now.

What I can't do:

  • Can't use another Mac to do anything such as target disk mode (no firewire cable).

My iMac Specs:

iMac (21.5-inch, Mid 2010) - Technical Specifications

21.5 inch, 3.06 Mhz, has OSX 10.10 installed with Windows and Ubuntu 14.04.2 LTS.

  • Also, I can't hear startup chimes, so I might not be able to clear the NVRAM/PRAM correctly. – Relative Jul 28 '15 at 15:40
  • I have Ubuntu 14 installed along with OS X 10.10.4 and Windows 8.1 on my mid 2007 20 inch iMac. You have not yet asked a question. Do you have one? BTW, you probably erased both OS X and the Recovery partitions. Did your model come with an OS X installation DVD? In not, then did you create a Recovery Mode USB flash drive? You can try booting using Command-Option-R, but your model might be to old to do this. – David Anderson Jul 28 '15 at 19:02
1

Fixed after many days. I noticed that the keyboard wasn't initializing during boot so I picked up a new keyboard(something I didn't even think of at the time) and it initialized. I held the Option/Alt key and to prevent this from happening again I installed rEFInd.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .