1

While normal hotspot interaction functions perfectly between an iPhone 6 (iOS 8.4) and my MBPr '14 with Yosemite 10.10.4, the Instant Hotspot feature does not. This feature used to work, but after some time this feature stopped working. I found the source of the issue, but can't determine how to resolve it.

My Yosemite logs reveal some errors.

com.apple.preferences.icloud.remoteservice[749]: [-[CastlePlugin appleIDNeedsFixing]] accountsd[270]: Deleting com.apple.gs.appleid.auth service token AppleIDAuthAgent[286] SERVER AppleIDAuth: Forgetting account "<my-apple-id>@?????.???"

SDHotspotBrowser::appendHashToData:withType: No apple ID hash SDHotspotBrowser::restartAdvertisingTetheringRequest Did not start advertising request

Steps I've tried that have not worked:

  • Signing out and back in to AppleID on both devices
  • Clean restore of iOS to iPhone
  • Ensuring wifi and bluetooth enabled on both devices, neither with an active wifi connection
  • All the above steps with full LTE coverage and 12 inch proximity between devices
1

While other answers here may help troubleshooting other causes of instant hotpsot failure, mine was caused by having two iCloud accounts used for keeping some syncing features separate.

Steps I took to get it working:

  • Turn on bluetooth and wifi on both devices
  • Connect both devices to same home wifi connection
  • Sign out of all icloud accounts on both devices
  • Restart both devices
  • Sign into both icloud accounts on iphone
  • Sign into both icloud accounts on OS X
  • Restart both devices
  • Sign out of main icloud account on mac
  • Restart mac
  • Sign into main icloud account on mac
  • Restart mac
  • Sign out of main icloud account on iphone
  • Restart iphone
  • Sign into main icloud account on iphone
  • Restart iphone
  • Check wifi on mac, profit

In my OS X console, See confirmation of Handoff:

AppleIDAuthAgent[285]: SERVER AppleIDAuth: Adding certificate for "<my-apple-id>@?????.???", "<certificate number>" to keychain, serial#="<iOS device serial number>" (updateAccountWithCertificateResult()/AppleIDAuthenticationImpl.cpp #225) accountCheckDispatch

Note that correct Instant Hotspot functionality is as follows

  • Instant hotspot should show up even if "Personal Hotspot" is turned off on the iPhone
  • Instant hotspot should show up even if Mac and iPhone are connected to other Wifi networks
  • Instant hotspot should show up even if phone is locked and in your pocket
  • Instant hotspot should show up even if iPhone has never been paired to the mac before
  • Instant hotspot will not show up if bluetooth is turned off on either device

Your device should appear here

0

UPDATED to reflect confirmation an further testing of OP's solution.

In looking at the steps you have taken, I am assuming that by signing out and back into AppleID on both devices that you mean that the account in iCloud is the SAME if you look in settings iCloud on BOTH devices. If that isn't the case, then those need to be in sync. EDIT: Also as y3sh found out, having more than one iCloud account can cause additional issues.

Next open the Bluetooth Settings on both devices turn on their antennas. You will also need to have the WiFi antenna of your Mac turned on. It is not necessary to have the iPhone WiFi antenna on, so long as it is set up to use Cellular Data.

At this point you should be able to see your "Instant" Hotspot as a selection under your available WiFi Networks. Clicking on it will establish the link and takes care of the rest. You will not need to have established the link with Personal Hotspots before, and you will not need to add the password seen in Personal Hotspots. Instant Hotspots takes care of the log in for you automatically.

There is a switch under Settings> Personal Hotspots that will be automatically turned on by Instant Hotspot when it forms the connection. If you do not want your iPhone to continue broadcasting its Hotspot after you have completed your session, you may have to manually turn this option off. A blue menu bar at the top of your iPhone will tell you whether or not it is still broadcasting the Hotspot. There is a switch under Settings> Personal Hotspots that will be green. Switch that off and the Hotspot will stop broadcasting.

Another note is that you are NOT required to have Handoff under General>Handoff & Suggested Apps turned on on your iPhone in order to form the Instant Hotspot form the connection between your iPhone and your Mac.

After all of this you should see your iPhone as an option under WiFi on your MBP. If you click it, the Instant Hotspot should be established right away. And if you still can't get connected, you did get AppleCare, didn't you? ☺︎

  • Thanks for the thoughtful answer. It will go a long way in helping others. It didn't solve my problem, but I think this page can help provide more workarounds for odd issues rather than the dreaded "me too!" apple forums. Consider revising your answer, because it contains some innacuracies: personal hotspot does not need to be on, the device does not need to be paired over bluetooth at any point in time, and the iphone can remain in the mac's preferred networks. – y3sh Aug 1 '15 at 16:29
  • It appears that you only thing that you need is to have the same single iCloud account logged in on each device and Blue Tooth on and the Mac to have its WiFi antenna turned on. Instant Hotspot actually turns on Personal Hotspots for you on your iPhone. It also adds the iPhone and sign in data to your Network Preferences under Wi-Fi Preferred Networks. Also Handoff's can be turned off as well and it still works. – AMR Aug 1 '15 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .