0

I recently upgraded from Lion to Yosemite. Now using Mail 8.2 the welcome screen shows up with every launch of the program. Dis- and reenabling the IMAP account like proposed here did not fix it. What can I do?

1

As there were no other suggestions, I fully deleted ~/Library/Mail/V2 as well as ~/Library/Preferences/com.apple.mail.plist, rebooted the system, re-added my IMAP account and had my ~50k mails re-indexed. This took about two hours but now Mail.app behaves as expected (at least in this case).

0

I finally found it!

With Yosemite the available options for caching messages changed. Before there were 3 possible values for the key "CachePolicy" in Accounts.plist: "CacheAllMessages" (or missing value), "CacheNoMessages" and "CacheMessagesAsRead". Now there are only two options: "CacheAllMessages" (or missing value) and "CacheAllBodies" (meaning without attachments).

If there are Accounts with one of the deprecated options "CacheNoMessages" or "CacheMessagesAsRead" configured, the welcome screen will show until the caching option is actively changed in account settings. The other possibility is to manually remove all instances of the key "CachePolicy" from Accounts.plist.

  • After my reset and a the upgrade to El Capitan with Mail 9 I never experienced the described behavior again. Thank you very much for the late reply, anyway. – mcnesium Dec 9 '15 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .