1

In the last 24 hours, I've had my keyboard and trackpad completely stop responding. Both times it was while YouTube was playing, so I think the machine wasn't completely frozen, just the trackpad and keyboard not responding.

I even tried closing my macbook, and reopening a bit later in case it was just an overwhelmed processor or something. However, even on the login screen that resulted neither my built in trackpad or keyboard caused any input to register in the OSX sign in box. I didn't try an external keyboard or mouse, so IDK if that would have helped.

I was surfing some car sites and downloaded an XLS file with a bunch of wheel weights from some forum, so I'm a little paranoid that maybe there was a virus or something that came with the file.

The strange thing is both times a hard reset (held power for 5 seconds) worked, and the keyboard and trackpad were/are back to working order after reboot.

Any insights to what may be causing this, or how to remedy it?

Also, I did just install an OS X update after the first incident last night, but it happened again today, and there doesn't appear to be any other updates for my machine.

Machine specs:

  • MacBook Pro (Retina, 13-inch, Late 2013)
  • OSX Yosemite Ver 10.10.4
  • 2.8 GHz Intel Core i7
  • 16 GB 1600 MHz DDR3
  • Going to try resetting SCM and PRAM... – Joel Glovier Jul 27 '15 at 14:04
  • Did you solve it? I'm experiencing the same issues. – msbrogli Nov 16 '15 at 4:48
  • Yes, but I'm not even sure how. I'm not experiencing it anymore, but I don't recall ever identifying what steps solved it. It just hasn't happened in a while. Sorry that's not more helpful. I do know that I tried the following things: - reset SCM and PRAM - restarted machine - performed software update – Joel Glovier Nov 17 '15 at 19:57

You must log in to answer this question.

Browse other questions tagged .